]> git.pld-linux.org Git - packages/php.git/blob - php.spec
- test release (1.1)
[packages/php.git] / php.spec
1 #
2 #   oracle - with oracle support 
3 #   oci8   - with oci8 support
4 #       
5 Summary:        The PHP HTML-embedded scripting language for use with Apache
6 Summary(fr):    Le langage de script embarque-HTML PHP pour Apache
7 Summary(pl):    Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache
8 Name:           php
9 Version:        4.0.4
10 Release:        1.1
11 Epoch:          1
12 Group:          Libraries
13 Group(de):      Libraries
14 Group(fr):      Librairies
15 Group(pl):      Biblioteki
16 License:        The PHP license (see "LICENSE" file included in distribution)
17 Source0:        http://www.php.net/distributions/%{name}-%{version}.tar.gz
18 Source1:        FAQ.php
19 Source2:        %{name}.ini
20 Source3:        zend.gif
21 Source4:        http://www.php.net/distributions/manual.tar.gz
22 Source5:        php-module-install
23 Patch0:         %{name}-imap.patch
24 Patch1:         %{name}-mysql-socket.patch
25 Patch2:         %{name}-mail.patch
26 Patch5:         %{name}-no_libnsl.patch
27 Icon:           php4.gif
28 URL:            http://www.php.net/
29 BuildRequires:  apache(EAPI)-devel
30 BuildRequires:  zip
31 BuildRequires:  bison
32 BuildRequires:  flex
33 BuildRequires:  db3-devel >= 3.1.17
34 BuildRequires:  freetype-devel
35 BuildRequires:  gd-devel >= 1.8.3
36 BuildRequires:  gdbm-devel
37 BuildRequires:  imap-devel >= 4.7b-1
38 # I think jdk is better for java
39 # BuildRequires:        jdk
40 %{?bcond_on_java:BuildRequires: kaffe-devel}
41 BuildRequires:  libjpeg-devel
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libpng >= 1.0.8
44 BuildRequires:  libtiff-devel
45 BuildRequires:  mm-devel >= 1.1.3
46 %{!?bcond_off_ldap:BuildRequires: openldap-devel >= 2.0}
47 BuildRequires:  pam-devel
48 BuildRequires:  pdflib-devel >= 3.0
49 #BuildRequires: libxml-devel >= 2.0.0
50 BuildRequires:  postgresql-devel
51 BuildRequires:  recode-devel >= 3.5
52 BuildRequires:  t1lib-devel
53 BuildRequires:  unixODBC-devel
54 BuildRequires:  zlib-devel >= 1.0.9
55 BuildRequires:  ucd-snmp-devel >= 4.1
56 BuildRequires:  libmcrypt-devel >= 2.4.4
57 BuildRequires:  mhash-devel
58 BuildRequires:  libltdl-devel
59 BuildRequires:  bzip2-devel
60 BuildRequires:  gmp-devel
61 BuildRequires:  curl-devel
62 %if %(expr %{?bcond_on_openssl:1}%{!?bcond_on_openssl:0} + %{!?bcond_off_ldap:1}%{?bcond_off_ldap:0})
63 BuildRequires:  openssl-devel >= 0.9.6
64 %endif
65 Requires:       apache(EAPI) >= 1.3.9
66 Prereq:         /usr/sbin/apxs
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _pkglibdir      %{_libdir}/apache
70
71 %description
72 PHP is an HTML-embedded scripting language. PHP attempts to make it
73 easy for developers to write dynamically generated web pages. PHP also
74 offers built-in database integration for several commercial and
75 non-commercial database management systems, so writing a
76 database-enabled web page with PHP is fairly simple. The most common
77 use of PHP coding is probably as a replacement for CGI scripts. The
78 mod_php module enables the Apache web server to understand and process
79 the embedded PHP language in web pages. This package contains PHP
80 version %{version}. If you use applications which specifically rely on
81 PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
82 module contained in the phpfi package. If you're just starting with
83 PHP, you should install this package. You'll also need to install the
84 Apache web server.
85
86 %description -l fr
87 PHP est un langage de script embarque dans le HTM. PHP essaye de
88 rendre simple aux developpeurs d'ecrire des pages web generees
89 dynamiquement. PHP incorpore egalement une integration avec plusieurs
90 systemes de gestion de bases de donnees commerciaux et
91 non-connerciaux, qui rent facile la creation de pages web liees avec
92 des bases de donnees. L'utilisation la plus commune de PHP est
93 probablement en remplacement de scripts CGI. Le module mod_php permet
94 au serveur web apache de comprendre et de traiter le langage PHP
95 integre dans des pages web. Ce package contient PHP version
96 %{version}. Si vous utilisez des applications qui utilisent
97 specifiquement PHP/FI, vous devrez installer le module PHP/FI inclus
98 dans le package mod_php. Si vous debutez avec PHP, vous devriez
99 installer ce package. Vous aurez egalement besoin d'installer le
100 serveur web Apache.
101
102 %description -l pl
103 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w
104 plikach HTML. Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP
105 (jak np. Apache), który interpretuje te polecenia. Umo¿liwia to
106 tworzenie dynamicznie stron WWW. Spora czê¶æ sk³adni PHP zapo¿yczona
107 zosta³a z jêzyków: C, Java i Perl.
108
109 %package mysql
110 Summary:        MySQL database module for PHP
111 Summary(pl):    Modu³ bazy danych MySQL dla PHP
112 Group:          Libraries
113 Group(de):      Libraries
114 Group(fr):      Librairies
115 Group(pl):      Biblioteki
116 PreReq: %{name} = %{version}
117
118 %description mysql
119 This is a dynamic shared object (DSO) for Apache that will add MySQL
120 database support to PHP. If you need back-end support for MySQL, you
121 should install this package in addition to the main %{name} package.
122
123 %description mysql -l pl
124 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych MySQL.
125
126
127 %package pgsql
128 Summary:        PostgreSQL database module for PHP
129 Summary(pl):    Modu³ bazy danych PostgreSQL dla PHP
130 Group:          Libraries
131 Group(de):      Libraries
132 Group(fr):      Librairies
133 Group(pl):      Biblioteki
134 PreReq: %{name} = %{version}
135
136 %description pgsql
137 This is a dynamic shared object (DSO) for Apache that will add
138 PostgreSQL database support to PHP. If you need back-end support for
139 PostgreSQL, you should install this package in addition to the main
140 %{name} package.
141
142 %description pgsql -l pl
143 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych PostgreSQL.
144
145 %package oci8
146 Summary:        Oracle 8 database module for PHP
147 Summary(pl):    Modu³ bazy danych Oracle 8 dla PHP
148 Group:          Libraries
149 Group(de):      Libraries
150 Group(fr):      Librairies
151 Group(pl):      Biblioteki
152 PreReq: %{name} = %{version}
153 Autoreq:        false
154
155 %description oci8
156 This is a dynamic shared object (DSO) for Apache that will add Oracle
157 8 database support to PHP. If you need back-end support for Oracle 8,
158 you should install this package in addition to the main %{name}
159 package.
160
161 %description oci8 -l pl
162 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 8. }
163
164 %package oracle
165 Summary:        Oracle 7 database module for PHP
166 Summary(pl):    Modu³ bazy danych Oracle 7 dla PHP
167 Group:          Libraries
168 Group(de):      Libraries
169 Group(fr):      Librairies
170 Group(pl):      Biblioteki
171 PreReq: %{name} = %{version}
172 Autoreq:        false
173
174 %description oracle
175 This is a dynamic shared object (DSO) for Apache that will add Oracle
176 7 database support to PHP. If you need back-end support for Oracle 7,
177 you should install this package in addition to the main %{name}
178 package.
179
180 %description oracle -l pl
181 Modu³ PHP umo¿liwiaj±cy dostêp do bazy danych Oracle 7. }
182
183 %package gd
184 Summary:        GD extension module for PHP
185 Summary:        Modu³ GD dla PHP
186 Group:          Libraries
187 Group(de):      Libraries
188 Group(fr):      Librairies
189 Group(pl):      Biblioteki
190 PreReq: %{name} = %{version}
191
192 %description gd
193 This is a dynamic shared object (DSO) for Apache that will add GD
194 support to PHP. You should install this package in addition to the
195 main %{name} package if you want to create and manipulate images with
196 PHP.
197
198 %description gd -l pl
199
200 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
201 %package java
202 Summary:        Java extension module for PHP
203 Summary(pl):    Modu³ Javy dla PHP
204 Group:          Libraries
205 Group(de):      Libraries
206 Group(fr):      Librairies
207 Group(pl):      Biblioteki
208 PreReq: %{name} = %{version}
209
210 %description java
211 This is a dynamic shared object (DSO) for Apache that will add JAVA
212 support to PHP. This extension provides a simple and effective means
213 for creating and invoking methods on Java objects from PHP.
214
215 %description java -l pl
216 %endif
217
218 %package xml
219 Summary:        XML extension module for PHP
220 Summary(pl):    Modu³ XML dla PHP
221 Group:          Libraries
222 Group(de):      Libraries
223 Group(fr):      Librairies
224 Group(pl):      Biblioteki
225 PreReq: %{name} = %{version}
226
227 %description xml
228 This is a dynamic shared object (DSO) for Apache that will add XML
229 support to PHP. This extension lets you create XML parsers and then
230 define handlers for different XML events. If you want to be able to
231 parse XML documents you should install this package in addition to the
232 main %{name} package.
233
234 #%description xml -l pl
235
236 %package dba
237 Summary:        DBA extension module for PHP
238 Summary(pl):    Modu³ DBA dla PHP
239 Group:          Libraries
240 Group(de):      Libraries
241 Group(fr):      Librairies
242 Group(pl):      Biblioteki
243 PreReq: %{name} = %{version}
244
245 %description dba
246 This is a dynamic shared object (DSO) for Apache that will add
247 flat-file databases (DBA) support to PHP.
248
249 #%description dba -l pl
250
251 %package odbc
252 Summary:        ODBC extension module for PHP
253 Summary(pl):    Modu³ ODBC dla PHP
254 Group:          Libraries
255 Group(de):      Libraries
256 Group(fr):      Librairies
257 Group(pl):      Biblioteki
258 PreReq: %{name} = %{version}
259
260 %description odbc
261 This is a dynamic shared object (DSO) for Apache that will add
262 ODBC support to PHP.
263
264 #%description odbc -l pl
265
266 %package calendar
267 Summary:        Calendar extension module for PHP
268 Summary(pl):    Modu³ funkcji kalendarza dla PHP
269 Group:          Libraries
270 Group(de):      Libraries
271 Group(fr):      Librairies
272 Group(pl):      Biblioteki
273 PreReq: %{name} = %{version}
274
275 %description calendar
276 This is a dynamic shared object (DSO) for Apache that will add
277 calendar support to PHP.
278
279 #%description calendar -l pl
280
281 %package dbase
282 Summary:        DBase extension module for PHP
283 Summary(pl):    Modu³ DBase dla PHP
284 Group:          Libraries
285 Group(de):      Libraries
286 Group(fr):      Librairies
287 Group(pl):      Biblioteki
288 PreReq: %{name} = %{version}
289
290 %description dbase
291 This is a dynamic shared object (DSO) for Apache that will add DBase
292 support to PHP.
293
294 #%description dbase -l pl
295
296 %package filepro
297 Summary:        FilePro extension module for PHP
298 Summary(pl):    Modu³ FilePro dla PHP
299 Group:          Libraries
300 Group(de):      Libraries
301 Group(fr):      Librairies
302 Group(pl):      Biblioteki
303 PreReq: %{name} = %{version}
304
305 %description filepro
306 This is a dynamic shared object (DSO) for Apache that will add FilePro
307 support to PHP.
308
309 #%description filepro -l pl
310
311 %package posix
312 Summary:        POSIX extension module for PHP
313 Summary(pl):    Modu³ POSIX dla PHP
314 Group:          Libraries
315 Group(de):      Libraries
316 Group(fr):      Librairies
317 Group(pl):      Biblioteki
318 PreReq: %{name} = %{version}
319
320 %description posix
321 This is a dynamic shared object (DSO) for Apache that will add POSIX
322 functions support to PHP.
323
324 #%description posix -l pl
325
326 %package pcre
327 Summary:        PCRE extension module for PHP
328 Summary(pl):    Modu³ PCRE dla PHP
329 Group:          Libraries
330 Group(de):      Libraries
331 Group(fr):      Librairies
332 Group(pl):      Biblioteki
333 PreReq: %{name} = %{version}
334
335 %description pcre
336 This is a dynamic shared object (DSO) for Apache that will add Perl
337 Compatible Regular Expression support to PHP.
338
339 #%description pcre -l pl
340
341 %package sysvsem
342 Summary:        SysV sem extension module for PHP
343 Summary(pl):    Modu³ SysV sem dla PHP
344 Group:          Libraries
345 Group(de):      Libraries
346 Group(fr):      Librairies
347 Group(pl):      Biblioteki
348 PreReq: %{name} = %{version}
349
350 %description sysvsem
351 This is a dynamic shared object (DSO) for Apache that will add SysV
352 semafores support to PHP.
353
354 #%description sysvsem -l pl
355
356 %package sysvshm
357 Summary:        SysV shm extension module for PHP
358 Summary(pl):    Modu³ SysV shm dla PHP
359 Group:          Libraries
360 Group(de):      Libraries
361 Group(fr):      Librairies
362 Group(pl):      Biblioteki
363 PreReq: %{name} = %{version}
364
365 %description sysvshm
366 This is a dynamic shared object (DSO) for Apache that will add SysV
367 Shared Memory support to PHP.
368
369 #%description sysvshm -l pl
370
371 %package yp
372 Summary:        NIS (yp) extension module for PHP
373 Summary(pl):    Modu³ NIS (yp) dla PHP
374 Group:          Libraries
375 Group(de):      Libraries
376 Group(fr):      Librairies
377 Group(pl):      Biblioteki
378 PreReq: %{name} = %{version}
379
380 %description yp
381 This is a dynamic shared object (DSO) for Apache that will add NIS
382 (Yellow Pages) support to PHP.
383
384 #%description yp -l pl
385
386 %package bcmath
387 Summary:        bcmath extension module for PHP
388 Summary(pl):    Modu³ bcmath dla PHP
389 Group:          Libraries
390 Group(de):      Libraries
391 Group(fr):      Librairies
392 Group(pl):      Biblioteki
393 PreReq: %{name} = %{version}
394
395 %description bcmath
396 This is a dynamic shared object (DSO) for Apache that will add bc
397 style precision math functions support to PHP.
398
399 #%description bcmath -l pl
400
401 %package ftp
402 Summary:        FTP extension module for PHP
403 Summary(pl):    Modu³ FTP dla PHP
404 Group:          Libraries
405 Group(de):      Libraries
406 Group(fr):      Librairies
407 Group(pl):      Biblioteki
408 PreReq: %{name} = %{version}
409
410 %description ftp
411 This is a dynamic shared object (DSO) for Apache that will add FTP
412 support to PHP.
413
414 #%description ftp -l pl
415
416 %package zlib
417 Summary:        Zlib extension module for PHP
418 Summary(pl):    Modu³ zlib dla PHP
419 Group:          Libraries
420 Group(de):      Libraries
421 Group(fr):      Librairies
422 Group(pl):      Biblioteki
423 PreReq: %{name} = %{version}
424
425 %description zlib
426 This is a dynamic shared object (DSO) for Apache that will add
427 commpresion (zlib) support to PHP.
428
429 #%description zlib -l pl
430
431 %package exif
432 Summary:        exifextension module for PHP
433 Summary(pl):    Modu³ exif dla PHP
434 Group:          Libraries
435 Group(de):      Libraries
436 Group(fr):      Librairies
437 Group(pl):      Biblioteki
438 PreReq: %{name} = %{version}
439
440 %description exif
441 This is a dynamic shared object (DSO) for Apache that will add exif
442 support to PHP.
443
444 #%description exif -l pl
445
446 %package recode
447 Summary:        recodeextension module for PHP
448 Summary(pl):    Modu³ recode dla PHP
449 Group:          Libraries
450 Group(de):      Libraries
451 Group(fr):      Librairies
452 Group(pl):      Biblioteki
453 PreReq: %{name} = %{version}
454
455 %description recode
456 This is a dynamic shared object (DSO) for Apache that will add recode
457 support to PHP.
458
459 #%description recode -l pl
460
461 %package session
462 Summary:        sessionextension module for PHP
463 Summary(pl):    Modu³ session dla PHP
464 Group:          Libraries
465 Group(de):      Libraries
466 Group(fr):      Librairies
467 Group(pl):      Biblioteki
468 PreReq: %{name} = %{version}
469
470 %description session
471 This is a dynamic shared object (DSO) for Apache that will add session
472 support to PHP.
473
474 #%description session -l pl
475
476 %package gettext
477 Summary:        gettextextension module for PHP
478 Summary(pl):    Modu³ gettext dla PHP
479 Group:          Libraries
480 Group(de):      Libraries
481 Group(fr):      Librairies
482 Group(pl):      Biblioteki
483 PreReq: %{name} = %{version}
484
485 %description gettext
486 This is a dynamic shared object (DSO) for Apache that will add gettext
487 support to PHP.
488
489 #%description gettext -l pl
490
491
492 %package snmp
493 Summary:        snmpextension module for PHP
494 Summary(pl):    Modu³ snmp dla PHP
495 Group:          Libraries
496 Group(de):      Libraries
497 Group(fr):      Librairies
498 Group(pl):      Biblioteki
499 PreReq: %{name} = %{version}
500
501 %description snmp
502 This is a dynamic shared object (DSO) for Apache that will add snmp
503 support to PHP.
504
505 #%description snmp -l pl
506
507 %package imap
508 Summary:        imapextension module for PHP
509 Summary(pl):    Modu³ imap dla PHP
510 Group:          Libraries
511 Group(de):      Libraries
512 Group(fr):      Librairies
513 Group(pl):      Biblioteki
514 PreReq: %{name} = %{version}
515
516 %description imap
517 This is a dynamic shared object (DSO) for Apache that will add imap
518 support to PHP.
519
520 #%description imap -l pl
521
522 %package ldap
523 Summary:        LDAP extension module for PHP
524 Summary(pl):    Modu³ LDAP dla PHP
525 Group:          Libraries
526 Group(de):      Libraries
527 Group(fr):      Librairies
528 Group(pl):      Biblioteki
529 PreReq: %{name} = %{version}
530
531 %description ldap
532 This is a dynamic shared object (DSO) for Apache that will add LDAP
533 support to PHP.
534
535 #%description ldap -l pl
536
537 %package sockets
538 Summary:        sockets extension module for PHP
539 Summary(pl):    Modu³ socket dla PHP
540 Group:          Libraries
541 Group(de):      Libraries
542 Group(fr):      Librairies
543 Group(pl):      Biblioteki
544 PreReq: %{name} = %{version}
545
546 %description sockets
547 This is a dynamic shared object (DSO) for Apache that will add sockets
548 support to PHP.
549
550 #%description sockets -l pl
551
552 %package mcrypt
553 Summary:        mcrypt extension module for PHP
554 Summary(pl):    Modu³ mcrypt dla PHP
555 Group:          Libraries
556 Group(de):      Libraries
557 Group(fr):      Librairies
558 Group(pl):      Biblioteki
559 PreReq: %{name} = %{version}
560
561 %description mcrypt
562 This is a dynamic shared object (DSO) for Apache that will add mcrypt
563 support to PHP.
564
565 #%description mcrypt -l pl
566
567 %package mhash
568 Summary:        mhash extension module for PHP
569 Summary(pl):    Modu³ mhash dla PHP
570 Group:          Libraries
571 Group(de):      Libraries
572 Group(fr):      Librairies
573 Group(pl):      Biblioteki
574 PreReq: %{name} = %{version}
575
576 %description mhash
577 This is a dynamic shared object (DSO) for Apache that will add mhash
578 support to PHP.
579
580 #%description mcrypt -l pl
581
582
583 %package doc
584 Summary:        Online manual for PHP
585 Summary(pl):    Dokumentacja dla PHP
586 Group:          Networking/Daemons
587 Group(de):      Netzwerkwesen/Server
588 Group(pl):      Sieciowe/Serwery
589
590 %description doc
591 Comprehensive documentation for PHP, viewable through your web
592 server, too!
593
594 %description doc -l pl
595 Dokumentacja dla pakietu PHP. Mo¿na j± równie¿ ogl±daæ poprzez serwer
596 WWW.
597
598 %prep
599 %setup  -q
600 %patch0 -p1
601 %patch1 -p1
602 %patch2 -p1
603 %patch5 -p1
604
605 %build
606 CFLAGS="$RPM_OPT_FLAGS -DEAPI -I/usr/X11R6/include"; export CFLAGS
607 ./buildconf
608 %configure \
609         --with-apxs=/usr/sbin/apxs \
610         --with-config-file-path=%{_sysconfdir}/httpd \
611         --with-exec-dir=%{_bindir} \
612         --disable-debug \
613         --enable-magic-quotes \
614         --enable-shared \
615         --enable-track-vars \
616         --enable-safe-mode \
617         --enable-trans-sid \
618         --enable-sysvsem=shared \
619         --enable-sysvshm=shared \
620         --enable-shmop=shared \
621         --enable-session \
622         --enable-exif=shared \
623         --with-regex=system \
624         --with-gettext=shared \
625         %{!?bcond_off_ldap:--with-ldap=shared} \
626         --with-mysql=shared \
627         --with-mysql-sock=/var/lib/mysql/mysql.sock \
628         --with-gd=shared \
629          --enable-gd-imgstrttf \
630         --with-dbase=shared \
631         --with-filepro=shared \
632         --enable-ftp=shared \
633         --with-hyperwave \
634         --with-pdflib=shared \
635         --with-cpdflib=shared \
636         %{?bcond_on_java:--with-java} \
637         --with-pgsql=shared,/usr \
638         --with-imap=shared \
639         --enable-bcmath=shared \
640         --enable-calendar=shared \
641         --with-mm \
642         --with-pcre-regex=shared \
643         --enable-posix=shared \
644         --with-ttf \
645         --with-t1lib \
646         --with-recode=shared \
647         --enable-ucd-snmp-hack \
648         --enable-dba=shared \
649         --with-snmp=shared \
650         --with-openssl \
651         --with-gdbm \
652         --with-db3 \
653         --enable-yp=shared \
654         --with-xml=shared \
655         --enable-xml=shared \
656         --with-zlib=shared \
657         --with-mcrypt=shared \
658         --enable-sockets=shared \
659         --with-bz2=shared \
660         --with-ctype=shared \
661         --with-mhash=shared \
662         --with-curl=shared \
663         --with-gmp=shared \
664         %{?bcond_on_openssl:--with-openssl} \
665         --with-unixODBC=shared \
666         %{?bcond_on_oracle:--with-oracle=shared} \
667         %{?bcond_on_oci8:--with-oci8=shared} \
668         --without-db2 
669
670
671
672 # TODO --with-pspell=/usr,shared (pspell missing)
673 #       --with-unixODBC=shared (nie jest shared)
674
675 #       --with-db3 \
676
677 # snmp won
678
679 #Syntax error on line 228 of %{_sysconfdir}/httpd/httpd.conf: Cannot load %{_libdir}/apache/libphp4.so into server: %{_libdir}/apache/libphp4.so: undefined symbol: phpi_get_le_gd
680 # Solution: make pdf and cpdf shared
681 #       --with-gd=shared \
682
683 #       --with-unixODBC \
684
685 # This option get trouble with imap
686 #       --enable-versioning \
687
688 # To old/new libmcrypt ?
689 #       --with-mcrypt=shared \
690 # --with-dom=%{_prefix}/X11R6 \
691
692 %{__make}
693
694 %install
695 rm -rf $RPM_BUILD_ROOT
696 install -d $RPM_BUILD_ROOT{%{_pkglibdir}/php,%{_sysconfdir}/httpd} \
697                 $RPM_BUILD_ROOT/home/httpd/html/{icons,docs,docs/php4-doc} \
698                 $RPM_BUILD_ROOT/%{_sbindir}
699
700 install .libs/*.so      $RPM_BUILD_ROOT%{_pkglibdir}
701 install modules/*.so    $RPM_BUILD_ROOT%{_pkglibdir}/php
702
703 install %{SOURCE2}              $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
704 install %{SOURCE3} php4.gif     $RPM_BUILD_ROOT/home/httpd/html/icons
705 install %{SOURCE5} $RPM_BUILD_ROOT/%{_sbindir}
706
707 tar zxf %{SOURCE4} -C $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc
708 ln -s manual.html $RPM_BUILD_ROOT/home/httpd/html/docs/php4-doc/index.html
709
710 install %{SOURCE1} .
711 gzip -9nf CODING_STANDARDS CREDITS FUNCTION_LIST.txt \
712       EXTENSIONS NEWS TODO* LICENSE Zend/LICENSE \
713       Zend/ZEND_CHANGES README.SELF-CONTAINED-EXTENSIONS README.EXT_SKEL
714
715 %post
716 /usr/sbin/apxs -e -a -n php4 %{_pkglibdir}/libphp4.so 1>&2
717 perl -pi -e 's|^#AddType application/x-httpd-php .php|AddType application/x-httpd-php .php|'
718 if [ -f /var/lock/subsys/httpd ]; then
719         /etc/rc.d/init.d/httpd restart 1>&2
720 fi
721
722 %postun
723 perl -pi -e 's|^AddType application/x-httpd-php .php|#AddType application/x-httpd-php .php|'
724 if [ -f /var/lock/subsys/httpd ]; then
725       /etc/rc.d/init.d/httpd restart 1>&2
726 fi
727
728 %preun
729 if [ "$1" = "0" ]; then
730         /usr/sbin/apxs -e -A -n php4 %{_pkglibdir}/libphp4.so 1>&2
731         if [ -f /var/lock/subsys/httpd ]; then
732                 /etc/rc.d/init.d/httpd restart 1>&2
733         fi
734 fi
735
736
737 %post bcmath
738 %{_sbindir}/php-module-install install bcmath /etc/httpd/php.ini
739
740 %preun bcmath
741 if [ "$1" = "0" ]; then
742         %{_sbindir}/php-module-install remove bcmath /etc/httpd/php.ini
743 fi
744
745 %post calendar
746 %{_sbindir}/php-module-install install calendar /etc/httpd/php.ini
747
748 %preun calendar
749 if [ "$1" = "0" ]; then
750         %{_sbindir}/php-module-install remove calendar /etc/httpd/php.ini
751 fi
752
753 %post dba
754 %{_sbindir}/php-module-install install dba /etc/httpd/php.ini
755
756 %preun dba
757 if [ "$1" = "0" ]; then
758         %{_sbindir}/php-module-install remove dba /etc/httpd/php.ini
759 fi
760
761 %post dbase
762 %{_sbindir}/php-module-install install dbase /etc/httpd/php.ini
763
764 %preun dbase
765 if [ "$1" = "0" ]; then
766         %{_sbindir}/php-module-install remove dbase /etc/httpd/php.ini
767 fi
768
769 %post exif
770 %{_sbindir}/php-module-install install exif /etc/httpd/php.ini
771
772 %preun exif
773 if [ "$1" = "0" ]; then
774         %{_sbindir}/php-module-install remove exif /etc/httpd/php.ini
775 fi
776
777 %post filepro
778 %{_sbindir}/php-module-install install filepro /etc/httpd/php.ini
779
780 %preun filepro
781 if [ "$1" = "0" ]; then
782         %{_sbindir}/php-module-install remove filepro /etc/httpd/php.ini
783 fi
784
785 %post ftp
786 %{_sbindir}/php-module-install install ftp /etc/httpd/php.ini
787
788 %preun ftp
789 if [ "$1" = "0" ]; then
790         %{_sbindir}/php-module-install remove ftp /etc/httpd/php.ini
791 fi
792
793 %post gd
794 %{_sbindir}/php-module-install install gd /etc/httpd/php.ini
795
796 %preun gd
797 if [ "$1" = "0" ]; then
798         %{_sbindir}/php-module-install remove gd /etc/httpd/php.ini
799 fi
800
801 %post gettext
802 %{_sbindir}/php-module-install install gettext /etc/httpd/php.ini
803
804 %preun gettext
805 if [ "$1" = "0" ]; then
806         %{_sbindir}/php-module-install remove gettext /etc/httpd/php.ini
807 fi
808
809 %post imap
810 %{_sbindir}/php-module-install install imap /etc/httpd/php.ini
811
812 %preun imap
813 if [ "$1" = "0" ]; then
814         %{_sbindir}/php-module-install remove imap /etc/httpd/php.ini
815 fi
816
817 %if %{?bond_on_java:1}%{!?bond_on_java:0}
818 %post java
819 %{_sbindir}/php-module-install install libphp_java /etc/httpd/php.ini
820
821 %preun java
822 if [ "$1" = "0" ]; then
823         %{_sbindir}/php-module-install remove libphp_java /etc/httpd/php.ini
824 fi
825 %endif
826
827 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
828 %post ldap
829 %{_sbindir}/php-module-install install ldap /etc/httpd/php.ini
830
831 %preun ldap
832 if [ "$1" = "0" ]; then
833         %{_sbindir}/php-module-install remove ldap /etc/httpd/php.ini
834 fi
835 %endif
836
837 %post mcrypt
838 %{_sbindir}/php-module-install install mcrypt /etc/httpd/php.ini
839
840 %preun mcrypt
841 if [ "$1" = "0" ]; then
842         %{_sbindir}/php-module-install remove mcrypt /etc/httpd/php.ini
843 fi
844
845 %post mhash
846 %{_sbindir}/php-module-install install mhash /etc/httpd/php.ini
847
848 %preun mhash
849 if [ "$1" = "0" ]; then
850         %{_sbindir}/php-module-install remove mhash /etc/httpd/php.ini
851 fi
852
853 %post mysql
854 %{_sbindir}/php-module-install install mysql /etc/httpd/php.ini
855
856 %preun mysql
857 if [ "$1" = "0" ]; then
858         %{_sbindir}/php-module-install remove mysql /etc/httpd/php.ini
859 fi
860
861 %if %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
862 %post oci8
863 %{_sbindir}/php-module-install install oci8 /etc/httpd/php.ini
864
865 %preun oci8
866 if [ "$1" = "0" ]; then
867         %{_sbindir}/php-module-install remove oci8 /etc/httpd/php.ini
868 fi
869 %endif
870
871 %post odbc
872 %{_sbindir}/php-module-install install odbc /etc/httpd/php.ini
873
874 %preun odbc
875 if [ "$1" = "0" ]; then
876         %{_sbindir}/php-module-install remove odbc /etc/httpd/php.ini
877 fi
878
879 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
880 %post oracle
881 %{_sbindir}/php-module-install install oracle /etc/httpd/php.ini
882
883 %preun oracle
884 if [ "$1" = "0" ]; then
885         %{_sbindir}/php-module-install remove oracle /etc/httpd/php.ini
886 fi
887 %endif
888
889 %post pcre
890 %{_sbindir}/php-module-install install pcre /etc/httpd/php.ini
891
892 %preun pcre
893 if [ "$1" = "0" ]; then
894         %{_sbindir}/php-module-install remove pcre /etc/httpd/php.ini
895 fi
896
897 %post pgsql
898 %{_sbindir}/php-module-install install pgsql /etc/httpd/php.ini
899
900 %preun pgsql
901 if [ "$1" = "0" ]; then
902         %{_sbindir}/php-module-install remove pgsql /etc/httpd/php.ini
903 fi
904
905 %post posix
906 %{_sbindir}/php-module-install install posix /etc/httpd/php.ini
907
908 %preun posix
909 if [ "$1" = "0" ]; then
910         %{_sbindir}/php-module-install remove posix /etc/httpd/php.ini
911 fi
912
913 %post recode
914 %{_sbindir}/php-module-install install recode /etc/httpd/php.ini
915
916 %preun recode
917 if [ "$1" = "0" ]; then
918         %{_sbindir}/php-module-install remove recode /etc/httpd/php.ini
919 fi
920
921 %post session
922 %{_sbindir}/php-module-install install session /etc/httpd/php.ini
923
924 %preun session
925 if [ "$1" = "0" ]; then
926         %{_sbindir}/php-module-install remove session /etc/httpd/php.ini
927 fi
928
929 %post snmp
930 %{_sbindir}/php-module-install install snmp /etc/httpd/php.ini
931
932 %preun snmp
933 if [ "$1" = "0" ]; then
934         %{_sbindir}/php-module-install remove snmp /etc/httpd/php.ini
935 fi
936
937 %post sockets
938 %{_sbindir}/php-module-install install sockets /etc/httpd/php.ini
939
940 %preun sockets
941 if [ "$1" = "0" ]; then
942         %{_sbindir}/php-module-install remove sockets /etc/httpd/php.ini
943 fi
944
945 %post sysvsem
946 %{_sbindir}/php-module-install install sysvsem /etc/httpd/php.ini
947
948 %preun sysvsem
949 if [ "$1" = "0" ]; then
950         %{_sbindir}/php-module-install remove sysvsem /etc/httpd/php.ini
951 fi
952
953 %post sysvshm
954 %{_sbindir}/php-module-install install sysvshm /etc/httpd/php.ini
955
956 %preun sysvshm
957 if [ "$1" = "0" ]; then
958         %{_sbindir}/php-module-install remove sysvshm /etc/httpd/php.ini
959 fi
960
961 %post xml
962 %{_sbindir}/php-module-install install xml /etc/httpd/php.ini
963
964 %preun xml
965 if [ "$1" = "0" ]; then
966         %{_sbindir}/php-module-install remove xml /etc/httpd/php.ini
967 fi
968
969 %post yp
970 %{_sbindir}/php-module-install install yp /etc/httpd/php.ini
971
972 %preun yp
973 if [ "$1" = "0" ]; then
974         %{_sbindir}/php-module-install remove yp /etc/httpd/php.ini
975 fi
976
977 %post zlib
978 %{_sbindir}/php-module-install install zlib /etc/httpd/php.ini
979
980 %preun zlib
981 if [ "$1" = "0" ]; then
982         %{_sbindir}/php-module-install remove zlib /etc/httpd/php.ini
983 fi
984
985 %clean
986 rm -rf $RPM_BUILD_ROOT
987
988 %files
989 %defattr(644,root,root,755)
990 %doc {CODING_STANDARDS,CREDITS,FUNCTION_LIST.txt,Zend/ZEND_CHANGES}.gz
991 %doc {LICENSE,Zend/LICENSE,EXTENSIONS,NEWS,TODO*}.gz  
992 %doc {README.EXT_SKEL,README.SELF-CONTAINED-EXTENSIONS}.gz
993
994 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
995 %dir %{_pkglibdir}/php
996
997 #%attr(755,root,root) %{_libdir}/apache/php/*.so
998
999 /home/httpd/html/icons/*
1000
1001 %attr(755,root,root) %{_pkglibdir}/libphp4.so
1002 %attr(755,root,root) %{_sbindir}/*
1003
1004 %files mysql
1005 %defattr(644,root,root,755)
1006 %attr(755,root,root) %{_pkglibdir}/php/mysql.so
1007
1008 %files pgsql
1009 %defattr(644,root,root,755)
1010 %attr(755,root,root) %{_pkglibdir}/php/pgsql.so
1011
1012 %if %{?bcond_on_oracle:1}%{!?bcond_on_oracle:0}
1013 %files oracle
1014 %defattr(644,root,root,755)
1015 %attr(755,root,root) %{_pkglibdir}/php/oracle.so
1016 %endif
1017
1018 %if  %{?bcond_on_oci8:1}%{!?bcond_on_oci8:0}
1019 %files oci8
1020 %defattr(644,root,root,755)
1021 %attr(755,root,root) %{_pkglibdir}/php/oci8.so
1022 %endif
1023
1024 %files gd
1025 %defattr(644,root,root,755)
1026 %attr(755,root,root) %{_pkglibdir}/php/gd.so
1027
1028 %files xml
1029 %defattr(644,root,root,755)
1030 %attr(755,root,root) %{_pkglibdir}/php/xml.so
1031
1032 %files dba
1033 %defattr(644,root,root,755)
1034 %attr(755,root,root) %{_pkglibdir}/php/dba.so
1035
1036 %files dbase
1037 %defattr(644,root,root,755)
1038 %attr(755,root,root) %{_pkglibdir}/php/dbase.so
1039
1040 %files filepro
1041 %defattr(644,root,root,755)
1042 %attr(755,root,root) %{_pkglibdir}/php/filepro.so
1043
1044 %files pcre
1045 %defattr(644,root,root,755)
1046 %attr(755,root,root) %{_pkglibdir}/php/pcre.so
1047
1048 %files posix
1049 %defattr(644,root,root,755)
1050 %attr(755,root,root) %{_pkglibdir}/php/posix.so
1051
1052 %files sysvsem
1053 %defattr(644,root,root,755)
1054 %attr(755,root,root) %{_pkglibdir}/php/sysvsem.so
1055
1056 %files sysvshm
1057 %defattr(644,root,root,755)
1058 %attr(755,root,root) %{_pkglibdir}/php/sysvshm.so
1059
1060 %files yp
1061 %defattr(644,root,root,755)
1062 %attr(755,root,root) %{_pkglibdir}/php/yp.so
1063
1064 %files calendar
1065 %defattr(644,root,root,755)
1066 %attr(755,root,root) %{_pkglibdir}/php/calendar.so
1067
1068 %files bcmath
1069 %defattr(644,root,root,755)
1070 %attr(755,root,root) %{_pkglibdir}/php/bcmath.so
1071
1072 %files ftp
1073 %defattr(644,root,root,755)
1074 %attr(755,root,root) %{_pkglibdir}/php/ftp.so
1075
1076 %files zlib
1077 %defattr(644,root,root,755)
1078 %attr(755,root,root) %{_pkglibdir}/php/zlib.so
1079
1080 %files exif
1081 %defattr(644,root,root,755)
1082 %attr(755,root,root) %{_pkglibdir}/php/exif.so
1083
1084 %files recode
1085 %defattr(644,root,root,755)
1086 %attr(755,root,root) %{_pkglibdir}/php/recode.so
1087
1088 #%files session
1089 #%defattr(644,root,root,755)
1090 #%attr(755,root,root) %{_pkglibdir}/php/session.so
1091
1092 %files gettext
1093 %defattr(644,root,root,755)
1094 %attr(755,root,root) %{_pkglibdir}/php/gettext.so
1095
1096 %files imap
1097 %defattr(644,root,root,755)
1098 %attr(755,root,root) %{_pkglibdir}/php/imap.so
1099
1100 %files snmp
1101 %defattr(644,root,root,755)
1102 %attr(755,root,root) %{_pkglibdir}/php/snmp.so
1103
1104 %if %{?bcond_on_java:1}%{!?bcond_on_java:0}
1105 %files java
1106 %defattr(644,root,root,755)
1107 %attr(755,root,root) %{_pkglibdir}/php/libphp_java.so
1108 %endif
1109
1110 %if %{?bcond_off_ldap:0}%{!?bcond_off_ldap:1}
1111 %files ldap
1112 %defattr(644,root,root,755)
1113 %attr(755,root,root) %{_pkglibdir}/php/ldap.so
1114 %endif
1115
1116 %files sockets
1117 %defattr(644,root,root,755)
1118 %attr(755,root,root) %{_pkglibdir}/php/sockets.so
1119
1120 %files mcrypt
1121 %defattr(644,root,root,755)
1122 %attr(755,root,root) %{_pkglibdir}/php/mcrypt.so
1123
1124 %files mhash
1125 %defattr(644,root,root,755)
1126 %attr(755,root,root) %{_pkglibdir}/php/mhash.so
1127
1128 %files odbc
1129 %defattr(644,root,root,755)
1130 %attr(755,root,root) %{_pkglibdir}/php/odbc.so
1131
1132 %files doc
1133 %defattr(644,root,root,755)
1134 /home/httpd/html/docs/php4-doc
This page took 0.102311 seconds and 3 git commands to generate.