]> git.pld-linux.org Git - packages/php-twig-Twig.git/blob - php-twig-Twig.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/php-twig-Twig.git] / php-twig-Twig.spec
1 %define         pearname        Twig
2 %define         php_min_version 5.2.4
3 Summary:        The flexible, fast, and secure template engine for PHP
4 Name:           php-twig-%{pearname}
5 Version:        1.29.0
6 Release:        1
7 License:        BSD Style
8 Group:          Development/Languages/PHP
9 Source0:        http://pear.twig-project.org/get/%{pearname}-%{version}.tgz
10 # Source0-md5:  728dd236dfa82f30fcb1d54ab1bf2672
11 URL:            http://twig.sensiolabs.org/
12 BuildRequires:  php-channel(pear.twig-project.org)
13 BuildRequires:  php-pear-PEAR
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.610
16 Requires:       php(core) >= %{php_min_version}
17 Requires:       php(ctype)
18 Requires:       php(date)
19 Requires:       php(dom)
20 Requires:       php(hash)
21 Requires:       php(json)
22 Requires:       php(mbstring)
23 Requires:       php(pcre)
24 Requires:       php(spl)
25 Requires:       php-channel(pear.twig-project.org)
26 Requires:       php-pear
27 Suggests:       php(xdebug)
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Twig is a template language for PHP.
33
34 Twig uses a syntax similar to the Django and Jinja template languages
35 which inspired the Twig runtime environment.
36
37 - Fast: Twig compiles templates down to plain optimized PHP code. The
38   overhead compared to regular PHP code was reduced to the very minimum.
39 - Secure: Twig has a sandbox mode to evaluate untrusted template code.
40   This allows Twig to be used as a template language for applications
41   where users may modify the template design.
42 - Flexible: Twig is powered by a flexible lexer and parser. This
43   allows the developer to define its own custom tags and filters, and
44   create its own DSL.
45
46 %prep
47 %pear_package_setup
48
49 mv docs/Twig/* .
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{php_pear_dir}
54 %pear_package_install
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc install.log
62 %doc README.rst CHANGELOG LICENSE
63 %{php_pear_dir}/.registry/.channel.*/*.reg
64 %{php_pear_dir}/Twig
This page took 0.063395 seconds and 3 git commands to generate.