]> git.pld-linux.org Git - packages/php-symfony2-Serializer.git/blob - php-symfony2-Serializer.spec
use autoloader.php as autoload bootstrap
[packages/php-symfony2-Serializer.git] / php-symfony2-Serializer.spec
1 %define         pearname        Serializer
2 %define         php_min_version 5.3.3
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Symfony2 Serializer Component
5 Name:           php-symfony2-Serializer
6 Version:        2.4.8
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        https://github.com/symfony/%{pearname}/archive/v%{version}/%{pearname}-%{version}.tar.gz
11 # Source0-md5:  b8290f40acc011d3de2e34f9c82d2319
12 URL:            http://symfony.com/doc/2.4/components/serializer.html
13 BuildRequires:  phpab
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.610
16 Requires:       php(core) >= %{php_min_version}
17 Requires:       php(ctype)
18 Requires:       php(dom)
19 Requires:       php(json)
20 Requires:       php(pcre)
21 Requires:       php(simplexml)
22 Requires:       php(spl)
23 Requires:       php(xml)
24 Requires:       php-pear >= 4:1.3.10
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The Serializer Component is meant to be used to turn objects into a
30 specific format (XML, JSON, Yaml, ...) and the other way around.
31
32 %prep
33 %setup -q -n %{pearname}-%{version}
34
35 %build
36 phpab -n -e '*/Tests/*' -o autoloader.php .
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}
41 cp -a *.php */ $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}
42 rm -r $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}/Tests
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc CHANGELOG.md LICENSE README.md
50 %dir %{php_pear_dir}/Symfony/Component/Serializer
51 %{php_pear_dir}/Symfony/Component/Serializer/*.php
52 %{php_pear_dir}/Symfony/Component/Serializer/Encoder
53 %{php_pear_dir}/Symfony/Component/Serializer/Exception
54 %{php_pear_dir}/Symfony/Component/Serializer/Normalizer
This page took 0.090395 seconds and 3 git commands to generate.