]> git.pld-linux.org Git - packages/php-symfony2-Serializer.git/blob - php-symfony2-Serializer.spec
4b70313e7d2d00b78b4897bc72dcd4591159698c
[packages/php-symfony2-Serializer.git] / php-symfony2-Serializer.spec
1 %define         pearname        Serializer
2 %define         php_min_version 5.3.3
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Symfony2 Serializer Component
5 Name:           php-symfony2-Serializer
6 Version:        2.3.4
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.symfony.com/get/%{pearname}-%{version}.tgz
11 # Source0-md5:  22caaf2fafd4a30193771aa775b64401
12 URL:            http://symfony.com/doc/current/components/serializer.html
13 BuildRequires:  php-channel(pear.symfony.com)
14 BuildRequires:  php-pear-PEAR
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.610
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php-channel(pear.symfony.com)
19 Requires:       php-pear >= 4:1.3.10
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Serializer Component is meant to be used to turn objects into a
25 specific format (XML, JSON, Yaml, ...) and the other way around.
26
27 %prep
28 %pear_package_setup
29
30 # no packaging of tests
31 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/Tests .
32 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/phpunit.xml.dist .
33
34 # fixups
35 mv docs/%{pearname}/Symfony/Component/%{pearname}/* .
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{php_pear_dir}
40 %pear_package_install
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc CHANGELOG.md LICENSE README.md install.log
48 %{php_pear_dir}/.registry/.channel.*/*.reg
49 %dir %{php_pear_dir}/Symfony/Component/Serializer
50 %{php_pear_dir}/Symfony/Component/Serializer/*.php
51 %{php_pear_dir}/Symfony/Component/Serializer/Encoder
52 %{php_pear_dir}/Symfony/Component/Serializer/Exception
53 %{php_pear_dir}/Symfony/Component/Serializer/Normalizer
This page took 0.047887 seconds and 2 git commands to generate.