]> git.pld-linux.org Git - packages/php-symfony2-Routing.git/blob - php-symfony2-Routing.spec
up to 2.3.4
[packages/php-symfony2-Routing.git] / php-symfony2-Routing.spec
1 %define         pearname        Routing
2 %define         php_min_version 5.3.3
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Symfony2 Routing Component
5 Name:           php-symfony2-Routing
6 Version:        2.3.4
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.symfony.com/get/%{pearname}-%{version}.tgz
11 # Source0-md5:  11304b23ff3fb1276bdd2c62294d993b
12 URL:            http://symfony.com/doc/current/components/routing/index.html
13 BuildRequires:  php-channel(pear.symfony.com)
14 BuildRequires:  php-pear-PEAR
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.610
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php-channel(pear.symfony.com)
19 Requires:       php-pear >= 4:1.3.10
20 Suggests:       php-symfony2-Config
21 Suggests:       php-symfony2-Yaml
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # exclude optional dependencies
26 %define         _noautoreq       pear(Config.*) pear(Yaml.*)
27
28 %description
29 The Routing Component maps an HTTP request to a set of configuration
30 variables.
31
32 %prep
33 %pear_package_setup
34
35 # no packaging of tests
36 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/Tests .
37 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/phpunit.xml.dist .
38
39 # fixups
40 mv docs/%{pearname}/Symfony/Component/%{pearname}/* .
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{php_pear_dir}
45 %pear_package_install
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc CHANGELOG.md LICENSE README.md install.log
53 %{php_pear_dir}/.registry/.channel.*/*.reg
54 %dir %{php_pear_dir}/Symfony/Component/Routing
55 %{php_pear_dir}/Symfony/Component/Routing/*.php
56 %{php_pear_dir}/Symfony/Component/Routing/Annotation
57 %{php_pear_dir}/Symfony/Component/Routing/Exception
58 %{php_pear_dir}/Symfony/Component/Routing/Generator
59 %{php_pear_dir}/Symfony/Component/Routing/Loader
60 %{php_pear_dir}/Symfony/Component/Routing/Matcher
This page took 0.076007 seconds and 3 git commands to generate.