]> git.pld-linux.org Git - packages/php-symfony2-Locale.git/blob - php-symfony2-Locale.spec
a5611c2b00d2c4dff2659e6a867c0e4815c193c1
[packages/php-symfony2-Locale.git] / php-symfony2-Locale.spec
1 # NOTE:
2 # The Locale component is deprecated since version 2.3 and will be removed in
3 # Symfony 3.0. You should use the more capable Intl component instead.
4 %define         package Locale
5 %define         php_min_version 5.3.9
6 %include        /usr/lib/rpm/macros.php
7 Summary:        Symfony2 Locale Component
8 Name:           php-symfony2-Locale
9 Version:        2.7.3
10 Release:        1
11 License:        MIT
12 Group:          Development/Languages/PHP
13 Source0:        https://github.com/symfony/%{package}/archive/v%{version}/%{package}-%{version}.tar.gz
14 # Source0-md5:  8d3eba870eca1e6848df7159a8d3b4bc
15 URL:            http://symfony.com/doc/2.2/components/locale.html
16 BuildRequires:  phpab
17 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
18 BuildRequires:  rpmbuild(macros) >= 1.610
19 Requires:       php(core) >= %{php_min_version}
20 Requires:       php(spl)
21 Requires:       php-pear >= 4:1.3.10
22 Requires:       php-symfony2-Intl >= 2.3
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Locale component provides fallback code to handle cases when the intl
28 extension is missing. Additionally it extends the implementation of a
29 native Locale class with several handy methods.
30
31 The Locale component is deprecated since version 2.3 and will be
32 removed in Symfony 3.0. You should use the more capable Intl component
33 instead.
34
35 %prep
36 %setup -q -n %{package}-%{version}
37
38 %build
39 phpab -n -e '*/Tests/*' -o autoloader.php .
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{package}
44 cp -a *.php */ $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{package}
45 rm -r $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{package}/Tests
46
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc CHANGELOG.md LICENSE README.md
54 %dir %{php_pear_dir}/Symfony/Component/Locale
55 %{php_pear_dir}/Symfony/Component/Locale/*.php
56 %{php_pear_dir}/Symfony/Component/Locale/Stub
57 %{php_pear_dir}/Symfony/Component/Locale/Exception
This page took 0.072121 seconds and 2 git commands to generate.