]> git.pld-linux.org Git - packages/php-symfony2-Intl.git/blob - php-symfony2-Intl.spec
up to 2.7.3-lts
[packages/php-symfony2-Intl.git] / php-symfony2-Intl.spec
1 %define         package Intl
2 %define         php_min_version 5.3.9
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Symfony2 Intl Component
5 Name:           php-symfony2-Intl
6 Version:        2.7.3
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        https://github.com/symfony/%{package}/archive/v%{version}/%{package}-%{version}.tar.gz
11 # Source0-md5:  6fd61e29f036b84fabc5a73b45061edf
12 URL:            http://symfony.com/doc/2.7/components/intl.html
13 BuildRequires:  phpab
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.674
16 Requires:       php(core) >= %{php_min_version}
17 Requires:       php(date)
18 Requires:       php(pcre)
19 Requires:       php(simplexml)
20 Requires:       php(spl)
21 Requires:       php-pear >= 4:1.3.10
22 Suggests:       php(intl)
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A PHP replacement layer for the C intl extension that also provides
28 access to the localization data of the ICU library.
29
30 The replacement layer is limited to the locale "en". If you want to
31 use other locales, you should install the intl extension instead.
32
33 %prep
34 %setup -q -n %{package}-%{version}
35
36 %build
37 phpab -n -e '*/Tests/*' -o autoloader.php .
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{package}
42 cp -a *.php */ $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{package}
43 rm -r $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{package}/Tests
44 # dev tools for Intl package maintainer
45 rm -r $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{package}/Resources/bin
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc LICENSE README.md CONTRIBUTING.md
53 %dir %{php_pear_dir}/Symfony/Component/Intl
54 %{php_pear_dir}/Symfony/Component/Intl/*.php
55 %{php_pear_dir}/Symfony/Component/Intl/Collator
56 %{php_pear_dir}/Symfony/Component/Intl/DateFormatter
57 %{php_pear_dir}/Symfony/Component/Intl/Exception
58 %{php_pear_dir}/Symfony/Component/Intl/Globals
59 %{php_pear_dir}/Symfony/Component/Intl/Locale
60 %{php_pear_dir}/Symfony/Component/Intl/NumberFormatter
61 %{php_pear_dir}/Symfony/Component/Intl/ResourceBundle
62 %{php_pear_dir}/Symfony/Component/Intl/Util
63
64 %dir %{php_pear_dir}/Symfony/Component/Intl/Resources
65 %{php_pear_dir}/Symfony/Component/Intl/Resources/stubs
This page took 0.094112 seconds and 4 git commands to generate.