]> git.pld-linux.org Git - packages/php-symfony2-Intl.git/blob - php-symfony2-Intl.spec
md5 fix
[packages/php-symfony2-Intl.git] / php-symfony2-Intl.spec
1 %define         pearname        Intl
2 %define         php_min_version 5.3.3
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Symfony2 Intl Component
5 Name:           php-symfony2-Intl
6 Version:        2.3.4
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.symfony.com/get/%{pearname}-%{version}.tgz
11 # Source0-md5:  ad30fce432b246619c096eeef44ad2bc
12 URL:            http://symfony.com/doc/current/components/intl.html
13 BuildRequires:  php-channel(pear.symfony.com)
14 BuildRequires:  php-pear-PEAR
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.674
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php-channel(pear.symfony.com)
19 Requires:       php-pear >= 4:1.3.10
20 Requires:       php-symfony2-Icu >= 1.0
21 Suggests:       php(intl)
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A PHP replacement layer for the C intl extension that also provides
27 access to the localization data of the ICU library.
28
29 The replacement layer is limited to the locale "en". If you want to
30 use other locales, you should install the intl extension instead.
31
32 %prep
33 %pear_package_setup
34
35 # no packaging of tests
36 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/Tests .
37 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/phpunit.xml.dist .
38
39 # dev tools
40 mv .%{php_pear_dir}/Symfony/Component/Intl/Resources/bin .
41
42 # fixups
43 mv docs/%{pearname}/Symfony/Component/%{pearname}/* .
44 mv .%{php_pear_dir}/Symfony/Component/Intl/CONTRIBUTING.md .
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{php_pear_dir}
49 %pear_package_install
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc LICENSE README.md CONTRIBUTING.md install.log
57 %{php_pear_dir}/.registry/.channel.*/*.reg
58 %dir %{php_pear_dir}/Symfony/Component/Intl
59 %{php_pear_dir}/Symfony/Component/Intl/*.php
60 %{php_pear_dir}/Symfony/Component/Intl/Collator
61 %{php_pear_dir}/Symfony/Component/Intl/DateFormatter
62 %{php_pear_dir}/Symfony/Component/Intl/Exception
63 %{php_pear_dir}/Symfony/Component/Intl/Globals
64 %{php_pear_dir}/Symfony/Component/Intl/Locale
65 %{php_pear_dir}/Symfony/Component/Intl/NumberFormatter
66 %{php_pear_dir}/Symfony/Component/Intl/ResourceBundle
67 %{php_pear_dir}/Symfony/Component/Intl/Util
68
69 %dir %{php_pear_dir}/Symfony/Component/Intl/Resources
70 %{php_pear_dir}/Symfony/Component/Intl/Resources/stubs
This page took 0.194914 seconds and 3 git commands to generate.