]> git.pld-linux.org Git - packages/php-symfony2-DependencyInjection.git/blob - php-symfony2-DependencyInjection.spec
a070adc2de46e8886c5a112ead4d8372851e442e
[packages/php-symfony2-DependencyInjection.git] / php-symfony2-DependencyInjection.spec
1 %define         pearname        DependencyInjection
2 %define         php_min_version 5.3.3
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Symfony2 DependencyInjection Component
5 Name:           php-symfony2-DependencyInjection
6 Version:        2.4.4
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.symfony.com/get/%{pearname}-%{version}.tgz
11 # Source0-md5:  b8884941cccbc8090198f97c3d700385
12 URL:            http://symfony.com/doc/2.4/components/dependency_injection/index.html
13 BuildRequires:  php-channel(pear.symfony.com)
14 BuildRequires:  php-pear-PEAR
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.610
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php(dom)
19 Requires:       php(pcre)
20 Requires:       php(simplexml)
21 Requires:       php(spl)
22 Requires:       php-channel(pear.symfony.com)
23 Requires:       php-pear >= 4:1.3.10
24 Suggests:       php-symfony2-Config
25 Suggests:       php-symfony2-ProxyManagerBridge
26 Suggests:       php-symfony2-Yaml
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The Dependency Injection component allows you to standardize and
32 centralize the way objects are constructed in your application.
33
34 %prep
35 %pear_package_setup
36
37 # no packaging of tests
38 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/Tests .
39 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/phpunit.xml.dist .
40
41 # fixups
42 mv docs/%{pearname}/Symfony/Component/%{pearname}/* .
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{php_pear_dir}
47 %pear_package_install
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc CHANGELOG.md LICENSE README.md install.log
55 %{php_pear_dir}/.registry/.channel.*/*.reg
56 %dir %{php_pear_dir}/Symfony/Component/DependencyInjection
57 %{php_pear_dir}/Symfony/Component/DependencyInjection/*.php
58 %{php_pear_dir}/Symfony/Component/DependencyInjection/Compiler
59 %{php_pear_dir}/Symfony/Component/DependencyInjection/Dumper
60 %{php_pear_dir}/Symfony/Component/DependencyInjection/Exception
61 %{php_pear_dir}/Symfony/Component/DependencyInjection/Extension
62 %{php_pear_dir}/Symfony/Component/DependencyInjection/LazyProxy
63 %{php_pear_dir}/Symfony/Component/DependencyInjection/Loader
64 %{php_pear_dir}/Symfony/Component/DependencyInjection/ParameterBag
This page took 0.053636 seconds and 2 git commands to generate.