]> git.pld-linux.org Git - packages/php-symfony2-Debug.git/blob - php-symfony2-Debug.spec
new, version 2.3.4
[packages/php-symfony2-Debug.git] / php-symfony2-Debug.spec
1 %define         pearname        Debug
2 %define         php_min_version 5.3.3
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Symfony2 Debug Component
5 Name:           php-symfony2-Debug
6 Version:        2.3.4
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.symfony.com/get/%{pearname}-%{version}.tgz
11 # Source0-md5:  a24d005d9aae72d98856da8f1b427e8f
12 URL:            http://symfony.com/doc/current/components/debug.html
13 BuildRequires:  php-channel(pear.symfony.com)
14 BuildRequires:  php-pear-PEAR
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.610
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php-channel(pear.symfony.com)
19 Requires:       php-pear >= 4:1.3.10
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Debug Component provides tools to ease debugging PHP code.
25
26 %prep
27 %pear_package_setup
28
29 # no packaging of tests
30 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/Tests .
31 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/phpunit.xml.dist .
32
33 # fixups
34 mv docs/%{pearname}/Symfony/Component/%{pearname}/* .
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{php_pear_dir}
39 %pear_package_install
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc CHANGELOG.md LICENSE README.md install.log
47 %{php_pear_dir}/.registry/.channel.*/*.reg
48 %dir %{php_pear_dir}/Symfony/Component/Debug
49 %{php_pear_dir}/Symfony/Component/Debug/*.php
50 %{php_pear_dir}/Symfony/Component/Debug/Exception
This page took 0.078595 seconds and 3 git commands to generate.