]> git.pld-linux.org Git - packages/php-symfony2-Config.git/blob - php-symfony2-Config.spec
up to 2.4.4
[packages/php-symfony2-Config.git] / php-symfony2-Config.spec
1 %define         pearname        Config
2 %define         php_min_version 5.3.3
3 %include        /usr/lib/rpm/macros.php
4 Summary:        Symfony2 Config Component
5 Name:           php-symfony2-Config
6 Version:        2.4.4
7 Release:        1
8 License:        MIT
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.symfony.com/get/%{pearname}-%{version}.tgz
11 # Source0-md5:  c9c16f5a0d3bf9e01d78b181664d4600
12 URL:            http://symfony.com/doc/2.4/components/config/index.html
13 BuildRequires:  php-channel(pear.symfony.com)
14 BuildRequires:  php-pear-PEAR
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.610
17 Requires:       php(core) >= %{php_min_version}
18 Requires:       php(ctype)
19 Requires:       php(json)
20 Requires:       php(pcre)
21 Requires:       php(spl)
22 Requires:       php(xml)
23 Requires:       php-channel(pear.symfony.com)
24 Requires:       php-pear >= 4:1.3.10
25 Requires:       php-symfony2-Filesystem >= 2.3
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Config Component provides several classes to help you find, load,
31 combine, autofill and validate configuration values of any kind,
32 whatever their source may be (Yaml, XML, INI files, or for instance a
33 database).
34
35 %prep
36 %pear_package_setup
37
38 # no packaging of tests
39 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/Tests .
40 mv .%{php_pear_dir}/Symfony/Component/%{pearname}/phpunit.xml.dist .
41
42 # fixups
43 mv docs/%{pearname}/Symfony/Component/%{pearname}/* .
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{php_pear_dir}
48 %pear_package_install
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc CHANGELOG.md LICENSE README.md install.log
56 %{php_pear_dir}/.registry/.channel.*/*.reg
57 %dir %{php_pear_dir}/Symfony/Component/Config
58 %{php_pear_dir}/Symfony/Component/Config/*.php
59 %{php_pear_dir}/Symfony/Component/Config/Definition
60 %{php_pear_dir}/Symfony/Component/Config/Exception
61 %{php_pear_dir}/Symfony/Component/Config/Loader
62 %{php_pear_dir}/Symfony/Component/Config/Resource
63 %{php_pear_dir}/Symfony/Component/Config/Util
This page took 0.067321 seconds and 3 git commands to generate.