]> git.pld-linux.org Git - packages/php-symfony-lexpress.git/blob - php-symfony-lexpress.spec
- or better avoid O/P since there are some incompatibilities
[packages/php-symfony-lexpress.git] / php-symfony-lexpress.spec
1 # TODO
2 # - use system creole, propel, phing packages (or better do not do that to avoid incompatibilities?)
3 # - php deps autofinder finds a lot of crap (that's why we use manual R now), maybe there is a way to improve
4 %define         pkgname symfony-lexpress
5 %define         php_min_version 5.3.4
6 #include        /usr/lib/rpm/macros.php
7 Summary:        Open-source PHP web framework
8 Summary(pl.UTF-8):      Szkielet aplikacji WWW w PHP o otwartych źródłach
9 Name:           php-%{pkgname}
10 Version:        1.5.3
11 Release:        1
12 License:        various free licenses (distributable)
13 Group:          Development/Languages/PHP
14 Source0:        https://github.com/LExpress/symfony1/archive/v%{version}.tar.gz
15 # Source0-md5:  e8b0f52bd71c07933c12f3319166fcbd
16 URL:            https://github.com/LExpress/symfony1
17 BuildRequires:  rpmbuild(macros) >= 1.461
18 Requires:       Smarty
19 Requires:       php(core) >= %{php_min_version}
20 Requires:       php(ctype)
21 Requires:       php-pear-Archive_Tar
22 Requires:       php-pear-Log
23 Requires:       php-pear-PEAR-core
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # bad depsolver
28 %define         _noautopear     pear(Doctrine/.* pear(PHPUnit/.*) pear(PHPUnit2/.*) pear(phing/.*) pear(propel/.*) pear(simpletest/.*)
29
30 # exclude optional php dependencies
31 %define         _noautophp      %{nil}
32
33 # put it together for rpmbuild
34 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
35
36 %description
37 This is fork of Symfony 1.4.
38
39 Based on the best practices of web development, thoroughly tried on
40 several active websites, symfony aims to speed up the creation and
41 maintenance of web applications, and to replace the repetitive coding
42 tasks by power, control and pleasure.
43
44 Symfony provides a lot of features seamlessly integrated together,
45 such as:
46 - simple templating and helpers
47 - cache management
48 - smart URLs
49 - scaffolding
50 - multilingualism and I18N support
51 - object model and MVC separation
52 - Ajax support
53 - enterprise ready
54
55 %description -l pl.UTF-8
56 To jest alternatywna wersja Symfony 1.4.
57
58 Oparty na najlepszych praktykach tworzenia aplikacji WWW, gruntownie
59 wypróbowany na kilku aktywnych serwisach moduł symfony próbuje
60 przyspieszyć tworzenie i utrzymywanie aplikacji WWW oraz zastąpić
61 powtarzające się zadania kodowania potęgą, kontrolą i przyjemnością.
62
63 Symfony udostępnia wiele zintegrowanych w sposób przezroczysty cech,
64 takich jak:
65 - proste szablony i odwołania
66 - zarządzanie pamięcią podręczną
67 - inteligentne URL-e
68 - scaffolding
69 - obsługa wielojęzyczności i międzynarodowości
70 - rozdzielenie modelu obiektowego i MVC
71 - obsługa AJAX
72 - gotowość na zastosowania enterprise
73
74 %prep
75 %setup  -q -n symfony1-%{version}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_data_dir}/%{pkgname}}
80
81 cp -a data lib $RPM_BUILD_ROOT%{php_data_dir}/%{pkgname}
82 ln -s %{php_data_dir}/%{pkgname}/data/bin/%{pkgname} $RPM_BUILD_ROOT%{_bindir}/%{pkgname}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc licenses CHANGELOG.md COPYRIGHT.md LICENSE.md README.md UPGRADE.md WHATS_NEW.md
90 %attr(755,root,root) %{_bindir}/*
91 %dir %{php_data_dir}/%{pkgname}
92 %dir %{php_data_dir}/%{pkgname}/data
93 %dir %{php_data_dir}/%{pkgname}/data/bin
94 %attr(755,root,root) %{php_data_dir}/%{pkgname}/data/bin/*
95 %{php_data_dir}/%{pkgname}/data/[!b]*
96 %{php_data_dir}/%{pkgname}/lib
This page took 0.099638 seconds and 3 git commands to generate.