]> git.pld-linux.org Git - packages/php-symfony-lexpress.git/blob - php-symfony-lexpress.spec
d0b4cc12fa4352ba5215b364e7bb854df98e903b
[packages/php-symfony-lexpress.git] / php-symfony-lexpress.spec
1 # TODO
2 # - use system creole, propel, phing packages (or better do not do that to avoid incompatibilities?)
3 # - php deps autofinder finds a lot of crap (that's why we use manual R now), maybe there is a way to improve
4 %define         pkgname symfony-lexpress
5 %define         php_min_version 5.3.4
6 #include        /usr/lib/rpm/macros.php
7 Summary:        Open-source PHP web framework
8 Summary(pl.UTF-8):      Szkielet aplikacji WWW w PHP o otwartych źródłach
9 Name:           php-%{pkgname}
10 Version:        1.5.3
11 Release:        1
12 License:        various free licenses (distributable)
13 Group:          Development/Languages/PHP
14 Source0:        https://github.com/LExpress/symfony1/archive/v%{version}.tar.gz
15 # Source0-md5:  e8b0f52bd71c07933c12f3319166fcbd
16 URL:            https://github.com/LExpress/symfony1
17 BuildRequires:  rpmbuild(macros) >= 1.461
18 Requires:       Smarty
19 Requires:       php(core) >= %{php_min_version}
20 Requires:       php(ctype)
21 Requires:       php-pear-Archive_Tar
22 Requires:       php-pear-Log
23 Requires:       php-pear-PEAR-core
24 Provides:       php-symfony
25 Obsoletes:      php-symfony
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # bad depsolver
30 %define         _noautopear     pear(Doctrine/.* pear(PHPUnit/.*) pear(PHPUnit2/.*) pear(phing/.*) pear(propel/.*) pear(simpletest/.*)
31
32 # exclude optional php dependencies
33 %define         _noautophp      %{nil}
34
35 # put it together for rpmbuild
36 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
37
38 %description
39 This is fork of Symfony 1.4.
40
41 Based on the best practices of web development, thoroughly tried on
42 several active websites, symfony aims to speed up the creation and
43 maintenance of web applications, and to replace the repetitive coding
44 tasks by power, control and pleasure.
45
46 Symfony provides a lot of features seamlessly integrated together,
47 such as:
48 - simple templating and helpers
49 - cache management
50 - smart URLs
51 - scaffolding
52 - multilingualism and I18N support
53 - object model and MVC separation
54 - Ajax support
55 - enterprise ready
56
57 %description -l pl.UTF-8
58 To jest alternatywna wersja Symfony 1.4.
59
60 Oparty na najlepszych praktykach tworzenia aplikacji WWW, gruntownie
61 wypróbowany na kilku aktywnych serwisach moduł symfony próbuje
62 przyspieszyć tworzenie i utrzymywanie aplikacji WWW oraz zastąpić
63 powtarzające się zadania kodowania potęgą, kontrolą i przyjemnością.
64
65 Symfony udostępnia wiele zintegrowanych w sposób przezroczysty cech,
66 takich jak:
67 - proste szablony i odwołania
68 - zarządzanie pamięcią podręczną
69 - inteligentne URL-e
70 - scaffolding
71 - obsługa wielojęzyczności i międzynarodowości
72 - rozdzielenie modelu obiektowego i MVC
73 - obsługa AJAX
74 - gotowość na zastosowania enterprise
75
76 %prep
77 %setup  -q -n symfony1-%{version}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_data_dir}/%{pkgname}}
82
83 cp -a data lib $RPM_BUILD_ROOT%{php_data_dir}/%{pkgname}
84 ln -s %{php_data_dir}/%{pkgname}/data/bin/%{pkgname} $RPM_BUILD_ROOT%{_bindir}/%{pkgname}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc licenses CHANGELOG.md COPYRIGHT.md LICENSE.md README.md UPGRADE.md WHATS_NEW.md
92 %attr(755,root,root) %{_bindir}/*
93 %dir %{php_data_dir}/%{pkgname}
94 %dir %{php_data_dir}/%{pkgname}/data
95 %dir %{php_data_dir}/%{pkgname}/data/bin
96 %attr(755,root,root) %{php_data_dir}/%{pkgname}/data/bin/*
97 %{php_data_dir}/%{pkgname}/data/[!b]*
98 %{php_data_dir}/%{pkgname}/lib
This page took 0.064119 seconds and 2 git commands to generate.