]> git.pld-linux.org Git - packages/php-seclib.git/blob - php-seclib.spec
bf0ac12418399b7f409b873b18ab55c390ea856e
[packages/php-seclib.git] / php-seclib.spec
1 # TODO
2 # - individual php-pear-XXX packages
3 #   http://phpseclib.sourceforge.net/pear.htm
4 #   pear remote-list -c phpseclib
5 #   this way it won't file-conflict with PEAR packages
6 # - patch location of CRYPT_RSA_OPENSSL_CONFIG (currently not installed)
7 %define         pkgname seclib
8 %define         php_min_version 5.2.0
9 %include        /usr/lib/rpm/macros.php
10 Summary:        PHP Secure Communications Library
11 Name:           php-%{pkgname}
12 Version:        0.3.5
13 Release:        1
14 License:        MIT
15 Group:          Development/Languages/PHP
16 Source0:        http://downloads.sourceforge.net/phpseclib/phpseclib%{version}.zip
17 # Source0-md5:  d4a0692a8c2d5ef919f8f867e3878a74
18 URL:            http://phpseclib.sourceforge.net/
19 BuildRequires:  php-pear-PEAR
20 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
21 BuildRequires:  rpmbuild(macros) >= 1.553
22 BuildRequires:  unzip
23 Patch0:         includes.patch
24 Requires:       php(bcmath)
25 Requires:       php(core) >= %{php_min_version}
26 Requires:       php(hash)
27 Requires:       php(openssl)
28 Requires:       php(pcre)
29 Requires:       php(xml)
30 Requires:       php-date
31 Requires:       php-pear
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Pure-PHP implementations of an arbitrary-precision integer arithmetic
37 library, fully PKCS#1 (v2.1) compliant RSA, DES, 3DES, RC4, Rijndael,
38 AES, SSH-1, SSH-2, and SFTP.
39
40 %prep
41 %setup -qc
42 %undos -f php
43 %patch0 -p1
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{php_pear_dir}
48 cp -a . $RPM_BUILD_ROOT%{php_pear_dir}
49
50 %{__rm} $RPM_BUILD_ROOT%{php_pear_dir}/openssl.cnf
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc openssl.cnf
58 %{php_pear_dir}/Crypt/AES.php
59 %{php_pear_dir}/Crypt/Blowfish.php
60 %{php_pear_dir}/Crypt/DES.php
61 %{php_pear_dir}/Crypt/Hash.php
62 %{php_pear_dir}/Crypt/Random.php
63 %{php_pear_dir}/Crypt/RC4.php
64 %{php_pear_dir}/Crypt/Rijndael.php
65 %{php_pear_dir}/Crypt/RSA.php
66 %{php_pear_dir}/Crypt/TripleDES.php
67 %{php_pear_dir}/Crypt/Twofish.php
68 %{php_pear_dir}/File/ANSI.php
69 %{php_pear_dir}/File/ASN1.php
70 %{php_pear_dir}/File/X509.php
71 %{php_pear_dir}/Math/BigInteger.php
72 %{php_pear_dir}/Net/SCP.php
73 %{php_pear_dir}/Net/SFTP.php
74 %dir %{php_pear_dir}/Net/SFTP
75 %{php_pear_dir}/Net/SFTP/Stream.php
76 %{php_pear_dir}/Net/SSH1.php
77 %{php_pear_dir}/Net/SSH2.php
This page took 0.075357 seconds and 2 git commands to generate.