]> git.pld-linux.org Git - packages/php-saucelabs-PHPUnit.git/blob - php-saucelabs-PHPUnit.spec
b5a44b014cf7180d140a7da9b0804f786cf43acf
[packages/php-saucelabs-PHPUnit.git] / php-saucelabs-PHPUnit.spec
1 %define         _status         stable
2 %define         _pearname PHPUnit
3 %define         php_min_version 5.2.7
4 %include        /usr/lib/rpm/macros.php
5 Summary:        %{_pearname} - regression testing framework for unit tests
6 Summary(pl.UTF-8):      %{_pearname} - zestaw testów regresyjnych
7 Name:           php-saucelabs-%{_pearname}
8 Version:        3.5.24
9 Release:        1
10 License:        BSD
11 Group:          Development/Languages/PHP
12 Source0:        http://saucelabs.github.com/pear/get/PHPUnit-%{version}.tgz
13 # Source0-md5:  1feb243062a70292b9707b992dee5d85
14 URL:            http://www.phpunit.de/
15 BuildRequires:  php-channel(components.ez.no)
16 BuildRequires:  php-channel(pear.symfony-project.com)
17 BuildRequires:  php-channel(saucelabs.github.com/pear)
18 BuildRequires:  php-pear >= 4:1.1-2
19 BuildRequires:  php-pear-PEAR >= 1:1.9.2
20 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
21 BuildRequires:  rpmbuild(macros) >= 1.473
22 Requires:       php-channel(pear.phpunit.de)
23 Requires:       php-common >= 4:%{php_min_version}
24 Requires:       php-dom
25 Requires:       php-pcre
26 Requires:       php-pear >= 4:1.1-2
27 Requires:       php-pear-XML_RPC2
28 Requires:       php-phpunit-DbUnit >= 1.0.0
29 Requires:       php-phpunit-File_Iterator >= 1.2.3
30 Requires:       php-phpunit-PHPUnit_MockObject >= 1.0.3
31 Requires:       php-phpunit-PHPUnit_Selenium >= 1.0.1
32 Requires:       php-phpunit-PHP_CodeCoverage >= 1.0.2
33 Requires:       php-phpunit-PHP_Timer >= 1.0.0
34 Requires:       php-phpunit-Text_Template >= 1.0.0
35 Requires:       php-reflection
36 Requires:       php-spl
37 Requires:       php-symfony-YAML >= 1.0.2
38 Suggests:       php-curl
39 Suggests:       php-dbus
40 Suggests:       php-json
41 Suggests:       php-pdo
42 Suggests:       php-simplexml
43 Suggests:       php-soap
44 Suggests:       php-tokenizer
45 Provides:       php-PHPUnit = %{version}
46 Obsoletes:      php-PHPUnit < 3.5
47 Obsoletes:      php-PHPUnit-tests
48 Obsoletes:      php-pear-PHPUnit
49 Obsoletes:      php-pear-PHPUnit2
50 BuildArch:      noarch
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 # exclude optional dependencies
54 %define         dep_optional    pear(Image/GraphViz.*) pear(Log.*) pear(SymfonyComponents/.*) pear(XML/RPC2/Client.php)
55
56 # put it together for rpmbuild
57 %define         _noautoreq      %{?dep_optional} %{?dep_missing}
58
59 %description
60 PHPUnit is a regression testing framework used by the developer who
61 implements unit tests in PHP. It is based upon JUnit, which can be
62 found at <http://www.junit.org/>.
63
64 In PEAR status of this package is: %{_status}.
65
66 %description -l pl.UTF-8
67 PHPUnit jest zestawem testów regresyjnych używanych przez developerów,
68 którzy implementują jednostki testowe w PHP. Jest bazowane na JUnit,
69 który można znaleźć pod adresem <http://www.junit.org/>.
70
71 Ta klasa ma w PEAR status: %{_status}.
72
73 %prep
74 %pear_package_setup
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{php_pear_dir}
79 install -d $RPM_BUILD_ROOT%{_bindir}
80 install -p usr/bin/phpunit $RPM_BUILD_ROOT%{_bindir}
81 %pear_package_install
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc install.log optional-packages.txt
89 %{php_pear_dir}/.registry/.channel.saucelabs.github.com_pear/phpunit.reg
90 %attr(755,root,root) %{_bindir}/phpunit
91 %{php_pear_dir}/PHPUnit
This page took 0.090038 seconds and 2 git commands to generate.