]> git.pld-linux.org Git - packages/php-redis.git/blob - php-redis.spec
provide versioned php extension dep
[packages/php-redis.git] / php-redis.spec
1 # TODO
2 # - use external igbinary and make it's dependency optional
3 #
4 # Conditional build:
5 %bcond_without  tests           # build without tests
6
7 %define         php_name        php%{?php_suffix}
8 %define         modname redis
9 Summary:        %{modname} A PHP extension for Redis
10 Name:           %{php_name}-%{modname}
11 Version:        2.2.5
12 Release:        3
13 License:        PHP 3.01
14 Group:          Development/Languages/PHP
15 Source0:        https://github.com/nicolasff/phpredis/tarball/%{version}/%{modname}-%{version}.tar.gz
16 # Source0-md5:  0e82aed77f2c23a9072b277ecdef6dba
17 Source1:        https://github.com/ukko/phpredis-phpdoc/tarball/master/%{modname}-phpdoc.tgz
18 # Source1-md5:  b7cce5ee29c6597e0fdd3557397e1b2a
19 URL:            https://github.com/nicolasff/phpredis
20 BuildRequires:  %{php_name}-devel >= 4:5.0.4
21 %{?with_tests:BuildRequires:    %{php_name}-session}
22 %{?with_tests:BuildRequires:    %{php_name}-simplexml}
23 %{?with_tests:BuildRequires:    /usr/bin/php}
24 BuildRequires:  rpmbuild(macros) >= 1.519
25 %{?requires_php_extension}
26 Requires:       %{php_name}-session
27 Provides:       php(%{modname}) = %{version}
28 Obsoletes:      php-redis < 2.2.5-1
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The phpredis extension provides an API for communicating with the
33 Redis key-value store.
34
35 This extension also provides session support.
36
37 %prep
38 %setup -qc -a1
39 mv nicolasff-php%{modname}-*/* .
40 mv ukko-phpredis-phpdoc-* phpdoc
41
42 %build
43 phpize
44 %configure
45 %{__make}
46
47 %if %{with tests}
48 # simple module load test
49 %{__php} -n \
50         -dextension_dir=modules \
51         -dextension=%{php_extensiondir}/simplexml.so \
52         -dextension=%{php_extensiondir}/spl.so \
53         -dextension=%{php_extensiondir}/session.so \
54         -dextension=%{modname}.so \
55         -m > modules.log
56 grep %{modname} modules.log
57 %endif
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %{__make} install \
62         EXTENSION_DIR=%{php_extensiondir} \
63         INSTALL_ROOT=$RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
66 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
67 ; Enable %{modname} extension module
68 extension=%{modname}.so
69 EOF
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 %php_webserver_restart
76
77 %postun
78 if [ "$1" = 0 ]; then
79         %php_webserver_restart
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc CREDITS README.markdown phpdoc
85 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
86 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.079167 seconds and 4 git commands to generate.