]> git.pld-linux.org Git - packages/php-pecl-yp.git/blob - php-pecl-yp.spec
bf4d167715064a87df166ed6bf3e110b1cf715b1
[packages/php-pecl-yp.git] / php-pecl-yp.spec
1 %define         rel                     2
2 %define         subver          RC1
3 %define         modname         yp
4 %define         status          beta
5 %define         php_name        php%{?php_suffix}
6 Summary:        %{modname} - YP/NIS functions
7 Summary(pl.UTF-8):      %{modname} - klient NIS dla PHP
8 Name:           %{php_name}-pecl-%{modname}
9 Version:        1.0.0
10 Release:        0.%{subver}.%{rel}
11 License:        PHP
12 Group:          Development/Languages/PHP
13 Source0:        http://pecl.php.net/get/%{modname}-%{version}%{subver}.tgz
14 # Source0-md5:  4ae09ff196f358a98a5f2cf30fabd733
15 URL:            http://pecl.php.net/package/yp/
16 BuildRequires:  %{php_name}-devel >= 4:5.3.0
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 Provides:       php(yp)
20 Obsoletes:      php-pecl-yp < 1.0.0-0.RC1.1
21 Obsoletes:      php-yp
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 NIS (formerly called Yellow Pages) allows network management of
26 important administrative files (e.g. the password file).
27
28 %description -l pl.UTF-8
29 Moduł PHP dodający wsparcie dla NIS (Yellow Pages).
30
31 %prep
32 %setup -qc
33 mv %{modname}-%{version}%{?subver}/* .
34
35 %build
36 phpize
37 %configure
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 %{__make} install \
43         EXTENSION_DIR=%{php_extensiondir} \
44         INSTALL_ROOT=$RPM_BUILD_ROOT
45
46 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CREDITS
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.199743 seconds and 2 git commands to generate.