]> git.pld-linux.org Git - packages/php-pecl-yp.git/blob - php-pecl-yp.spec
- php 5.5 rebuild
[packages/php-pecl-yp.git] / php-pecl-yp.spec
1 %define         php_name        php%{?php_suffix}
2 %define         snap            20060104
3 %define         modname yp
4 %define         status          stable
5 Summary:        %{modname} - a NIS client for PHP
6 Summary(pl.UTF-8):      %{modname} - klient NIS dla PHP
7 Name:           %{php_name}-pecl-%{modname}
8 Version:        0.%{snap}
9 Release:        8
10 License:        PHP
11 Group:          Development/Languages/PHP
12 Source0:        php-pecl-%{modname}-%{snap}.tar.gz
13 # Source0-md5:  ea77871191b0a32c4734964f7c02bc6c
14 URL:            http://cvs.php.net/pecl/yp/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.0
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(yp)
20 Obsoletes:      php-yp
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is a dynamic shared object (DSO) for PHP that will add NIS
25 (Yellow Pages) support.
26
27 %description -l pl.UTF-8
28 Moduł PHP dodający wsparcie dla NIS (Yellow Pages).
29
30 %prep
31 %setup -qc
32 mv php-pecl-%{modname}-%{snap}/* .
33
34 %build
35 phpize
36 %configure
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
42
43 install modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
44 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
45 ; Enable %{modname} extension module
46 extension=%{modname}.so
47 EOF
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 %php_webserver_restart
54
55 %postun
56 if [ "$1" = 0 ]; then
57         %php_webserver_restart
58 fi
59
60 %files
61 %defattr(644,root,root,755)
62 %doc CREDITS
63 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
64 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.086608 seconds and 3 git commands to generate.