]> git.pld-linux.org Git - packages/php-pecl-yp.git/blob - php-pecl-yp.spec
- updated to 1.0.1 release
[packages/php-pecl-yp.git] / php-pecl-yp.spec
1 %define         modname         yp
2 %define         status          beta
3 %define         php_name        php%{?php_suffix}
4 Summary:        %{modname} - YP/NIS functions
5 Summary(pl.UTF-8):      %{modname} - klient YP/NIS dla PHP
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.1
8 Release:        1
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  6c57bf144d1bb8c4aca5309cc4281407
13 URL:            http://pecl.php.net/package/yp/
14 BuildRequires:  %{php_name}-devel >= 4:5.3.0
15 BuildRequires:  libnsl-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Provides:       php(yp)
19 Obsoletes:      php-pecl-yp < 1.0.0-0.RC1.1
20 Obsoletes:      php-yp
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 NIS (formerly called Yellow Pages) allows network management of
25 important administrative files (e.g. the password file).
26
27 %description -l pl.UTF-8
28 Moduł PHP dodający obsługę NIS (Yellow Pages).
29
30 %prep
31 %setup -qc
32 %{__mv} %{modname}-%{version}/* .
33
34 %build
35 phpize
36 %configure
37 %{__make}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         EXTENSION_DIR=%{php_extensiondir} \
44         INSTALL_ROOT=$RPM_BUILD_ROOT
45
46 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CREDITS
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.06628 seconds and 3 git commands to generate.