]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blob - php-pecl-xdebug.spec
Up to 2.9.8
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
1 #
2 # Conditional build:
3 %bcond_without  vim             # make vim syntax package
4
5 # build noarch packages only for 7.0 version
6 %if 0%{?_pld_builder:1} && "%{?php_suffix}" != "70"
7 %undefine       with_vim
8 %endif
9
10 %define         php_name        php%{?php_suffix}
11 %define         modname xdebug
12 Summary:        %{modname} - provides functions for functions traces and profiling
13 Summary(pl.UTF-8):      %{modname} - funkcje do śledzenia i profilowania funkcji
14 Name:           %{php_name}-pecl-%{modname}
15 Version:        2.9.8
16 Release:        1
17 # The Xdebug License, version 1.01
18 # (Based on "The PHP License", version 3.0)
19 License:        PHP
20 Group:          Development/Languages/PHP
21 Source0:        https://xdebug.org/files/xdebug-%{version}.tgz
22 # Source0-md5:  a2b5199f11457099d5c81d02ababb87e
23 Source1:        %{modname}.ini
24 Source2:        vim-xt-filetype.vim
25 URL:            https://xdebug.org/
26 BuildRequires:  %{php_name}-devel >= 4:7.1.0
27 BuildRequires:  libedit-devel
28 BuildRequires:  libtool
29 BuildRequires:  rpmbuild(macros) >= 1.650
30 %{?requires_zend_extension}
31 Provides:       php(%{modname}) = %{version}
32 Obsoletes:      php-pecl-xdebug < 2.2.4-1
33 Conflicts:      ZendOptimizer
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _vimdatadir             %{_datadir}/vim
37
38 %description
39 The Xdebug extension helps you debugging your script by providing a
40 lot of valuable debug information. The debug information that Xdebug
41 can provide includes the following:
42
43 - stack and function traces in error messages with:
44  - full parameter display for user defined functions
45  - function name, file name and line indications
46  - support for member functions
47 - memory allocation
48 - protection for infinite recursions
49
50 Xdebug also provides:
51
52 - profiling information for PHP scripts
53 - code coverage analysis
54 - capabilities to debug your scripts interactively with a debug client
55
56 %description -l pl.UTF-8
57 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
58 dużo wartościowych informacji. Informacje przydatne do śledzenia,
59 które może zapewnić Xdebug, obejmują:
60
61 - śledzenie stosu i funkcji w komunikatach błędów wraz z:
62  - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
63    użytkownika
64  - nazwami funkcji, nazwami plików i numerami linii
65  - obsługą metod klas
66 - przydzielanie pamięci
67 - zabezpieczenie przed nieskończoną rekurencją
68
69 Xdebug dostarcza także:
70
71 - informacje do profilowania skryptów PHP
72 - analizę wywołań skryptu
73 - możliwość śledzenia skryptów interaktywnie przy pomocy klienta
74   odpluskwiacza
75
76 %package -n vim-syntax-xdebug
77 Summary:        Vim syntax: Xdebug trace files
78 Group:          Applications/Editors/Vim
79 Requires:       vim-rt >= 4:7.2.170
80 BuildArch:      noarch
81
82 %description -n vim-syntax-xdebug
83 This plugin provides syntax highlighting Xdebug trace files (context
84 or unified).
85
86 %prep
87 %setup -qc
88 mv %{modname}-%{version}*/* .
89
90 %{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
91
92 install -d vim/{syntax,ftdetect}
93 mv contrib/xt.vim vim/syntax
94 cp -p %{SOURCE2} vim/ftdetect/xt.vim
95
96 %build
97 phpize
98 %configure
99 %{__make}
100 cd debugclient
101 %configure \
102         --with-libedit
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
108
109 install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
110 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
111 cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
112
113 %if %{with vim}
114 # vim syntax
115 install -d $RPM_BUILD_ROOT%{_vimdatadir}
116 cp -a vim/* $RPM_BUILD_ROOT%{_vimdatadir}
117 %endif
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 %php_webserver_restart
124
125 %postun
126 if [ "$1" = 0 ]; then
127         %php_webserver_restart
128 fi
129
130 %files
131 %defattr(644,root,root,755)
132 %doc README.rst CREDITS contrib
133 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
134 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
135 %attr(755,root,root) %{_bindir}/xdebug*-debugclient
136
137 %if %{with vim}
138 %files -n vim-syntax-xdebug
139 %defattr(644,root,root,755)
140 %{_vimdatadir}/ftdetect/xt.vim
141 %{_vimdatadir}/syntax/xt.vim
142 %endif
This page took 0.182357 seconds and 3 git commands to generate.