]> git.pld-linux.org Git - packages/php-pecl-vld.git/blob - php-pecl-vld.spec
4b0815ce56698750b29e213d24b949e9a96d294c
[packages/php-pecl-vld.git] / php-pecl-vld.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         vld
3 Summary:        %{modname} - provides functionality to dump the internal representation of PHP scripts
4 Summary(pl.UTF-8):      %{modname} - dostarcza funkcjonalności do zrzutu wewnętrznej reprezentacji skryptów PHP
5 Name:           %{php_name}-pecl-%{modname}
6 Version:        0.12.0
7 Release:        2
8 License:        BSD style
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
11 # Source0-md5:  b2b156f1d4aae486f684872c4350b4fa
12 URL:            http://pecl.php.net/package/vld/
13 BuildRequires:  %{php_name}-devel >= 3:5.0.0
14 BuildRequires:  rpmbuild(macros) >= 1.650
15 %{?requires_php_extension}
16 Requires:       php(core) >= 5.0.4
17 Provides:       php(%{modname}) = %{version}
18 Obsoletes:      php-pear-%{modname}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The Vulcan Logic Disassembler hooks into the Zend Engine and dumps all
23 the opcodes (execution units) of a script.
24
25 %description -l pl.UTF-8
26 Vulcan Logic Disassembler podłącza się do silnika Zend i zwraca
27 wszystkie jednostki wykonawcze (tzw. opcody) danego skryptu.
28
29 %prep
30 %setup -qc
31 mv %{modname}-%{version}/* .
32
33 %build
34 phpize
35 %configure
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
41 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
42 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
43 ; Enable %{modname} extension module
44 extension=%{modname}.so
45 EOF
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 %php_webserver_restart
52
53 %postun
54 if [ "$1" = 0 ]; then
55         %php_webserver_restart
56 fi
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changelog CREDITS
61 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
62 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.055208 seconds and 2 git commands to generate.