]> git.pld-linux.org Git - packages/php-pecl-uuid.git/blob - php-pecl-uuid.spec
- php 5.5 rebuild
[packages/php-pecl-uuid.git] / php-pecl-uuid.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         uuid
3 %define         status          stable
4 Summary:        %{modname} - UUID support functions
5 Summary(pl.UTF-8):      %{modname} - funkcje obsługujące UUID
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.3
8 Release:        5
9 License:        LGPL
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  236c3f2f5c5e9ce0aa2f024618c060a1
13 URL:            http://pecl.php.net/package/uuid/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  libuuid-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 Obsoletes:      php-pear-%{modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This extension provides functions to generate and analyse universally
25 unique identifiers (UUIDs). It depends on external libuuid. This
26 library is available on most linux systems, its source is bundled with
27 ext2fs tools.
28
29 In PECL status of this package is: %{status}.
30
31 %description -l pl.UTF-8
32 To rozszerzenie dostarcza funkcje do generowania i analizy
33 uniwersalnie unikalnych identyfikatorów (ang. UUIDs). Rozszerznie to
34 wymaga zewnętrznej biblioteki libuuid, dostępnej w większości
35 dystrybucji, której źródło jest dostarczane wraz z narzędziami ext2fs.
36
37 To rozszerzenie ma w PECL status: %{status}.
38
39 %prep
40 %setup -qc
41 mv %{modname}-%{version}/* .
42
43 %build
44 phpize
45 %configure
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
51
52 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
53 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
54 ; Enable %{modname} extension module
55 extension=%{modname}.so
56 EOF
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %php_webserver_restart
63
64 %postun
65 if [ "$1" = 0 ]; then
66         %php_webserver_restart
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
72 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.123134 seconds and 3 git commands to generate.