]> git.pld-linux.org Git - packages/php-pecl-sphinx.git/blob - php-pecl-sphinx.spec
up to 1.3.2
[packages/php-pecl-sphinx.git] / php-pecl-sphinx.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         sphinx
3 Summary:        %{modname} - client for sphinx SQL full-text search engine
4 Name:           %{php_name}-pecl-%{modname}
5 Version:        1.3.2
6 Release:        1
7 License:        PHP 3.01
8 Group:          Development/Languages/PHP
9 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
10 # Source0-md5:  da44407c2ca6584fa5fa673bd0ac9708
11 URL:            http://pecl.php.net/package/sphinx/
12 BuildRequires:  %{php_name}-devel >= 4:5.0.4
13 BuildRequires:  libsphinxclient-devel
14 BuildRequires:  rpmbuild(macros) >= 1.650
15 %{?requires_php_extension}
16 Provides:       php(sphinx)
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Client extension for Sphinx - Opensource SQL full-text search engine.
21
22 %prep
23 %setup -qc
24 mv %{modname}-%{version}/* .
25
26 %build
27 phpize
28 %configure
29 %{__make}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
34
35 %{__make} install \
36         INSTALL_ROOT=$RPM_BUILD_ROOT \
37         EXTENSION_DIR=%{php_extensiondir}
38
39 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
40 ; Enable %{modname} extension module
41 extension=%{modname}.so
42 EOF
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 %php_webserver_restart
49
50 %postun
51 if [ "$1" = 0 ]; then
52         %php_webserver_restart
53 fi
54
55 %files
56 %defattr(644,root,root,755)
57 %doc CREDITS
58 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
59 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.05893 seconds and 3 git commands to generate.