]> git.pld-linux.org Git - packages/php-pecl-sphinx.git/blob - php-pecl-sphinx.spec
0619f0a315efdcb8038ef200bb8bfe8ac707ea14
[packages/php-pecl-sphinx.git] / php-pecl-sphinx.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         sphinx
3 Summary:        %{modname} - client for sphinx SQL full-text search engine
4 Name:           %{php_name}-pecl-%{modname}
5 Version:        1.3.0
6 Release:        2
7 License:        PHP 3.01
8 Group:          Development/Languages/PHP
9 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
10 # Source0-md5:  ee4dd6c33ad4082f1cdab6e9a7407f28
11 URL:            http://pecl.php.net/package/sphinx/
12 BuildRequires:  libsphinxclient-devel
13 BuildRequires:  %{php_name}-devel >= 4:5.0.4
14 BuildRequires:  rpmbuild(macros) >= 1.650
15 %{?requires_php_extension}
16 Provides:       php(sphinx)
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Client extension for Sphinx - Opensource SQL full-text search engine.
21
22 %prep
23 %setup -qc
24 mv %{modname}-%{version}/* .
25
26 %build
27 phpize
28 %configure
29 %{__make}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
34
35 %{__make} install \
36         INSTALL_ROOT=$RPM_BUILD_ROOT \
37         EXTENSION_DIR=%{php_extensiondir}
38 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
39 ; Enable %{modname} extension module
40 extension=%{modname}.so
41 EOF
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 %php_webserver_restart
48
49 %postun
50 if [ "$1" = 0 ]; then
51         %php_webserver_restart
52 fi
53
54 %files
55 %defattr(644,root,root,755)
56 %doc CREDITS
57 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
58 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.043964 seconds and 2 git commands to generate.