]> git.pld-linux.org Git - packages/php-pecl-pam.git/blob - php-pecl-pam.spec
81e05b7b2447bcb7aad094d20074cef999963dc0
[packages/php-pecl-pam.git] / php-pecl-pam.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname pam
3 %define         status  stable
4 Summary:        %{modname} - PAM integration
5 Summary(pl.UTF-8):      %{modname} - integracja z PAM-em
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.3
8 Release:        8
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  2dfd378a76021245050333cd4d49ed96
13 URL:            http://pecl.php.net/package/PAM/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  pam-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This extension provides PAM (Pluggable Authentication Modules)
24 integration. PAM is a system of libraries that handle the
25 authentication tasks of applications and services. The library
26 provides a stable API for applications to defer to for authentication
27 tasks.
28
29 In PECL status of this extension is: %{status}.
30
31 %description -l pl.UTF-8
32 Rozszerzenie to zapewnia integrację z systemem PAM (Pluggable
33 Authentication Modules). PAM to system bibliotek obsługujących proces
34 uwierzytelniania aplikacji i usług. Biblioteka dostarcza stabilne API
35 umożliwiające aplikacjom obsłużenie zadań uwierzytelniania.
36
37 To rozszerzenie ma w PECL status: %{status}.
38
39 %prep
40 %setup -qc
41 mv %{modname}-%{version}/* .
42
43 %build
44 phpize
45 %configure
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %{__make} install \
51         EXTENSION_DIR=%{php_extensiondir} \
52         INSTALL_ROOT=$RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
55 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
56 ; Enable %{modname} extension module
57 extension=%{modname}.so
58 EOF
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 %php_webserver_restart
65
66 %postun
67 if [ "$1" = 0 ]; then
68         %php_webserver_restart
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc CREDITS README
74 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
75 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.072952 seconds and 2 git commands to generate.