]> git.pld-linux.org Git - packages/php-pecl-oauth.git/blob - php-pecl-oauth.spec
18d00ff59d6d309c63c6cd195bc0ee69f36321ee
[packages/php-pecl-oauth.git] / php-pecl-oauth.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname oauth
3 %define         status  stable
4 Summary:        %{modname} - consumer extension
5 Summary(pl.UTF-8):      %{modname} - rozszerzenie klienckie
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.2.3
8 Release:        4
9 License:        BSD
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  99838d9a04b78058c7360dfd69c8593b
13 URL:            http://pecl.php.net/package/oauth/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       %{php_name}-hash
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 OAuth is an authorization protocol built on top of HTTP which allows
24 applications to securely access data without having to store usernames
25 and passwords.
26
27 In PECL status of this extension is: %{status}.
28
29 %description -l pl.UTF-8
30 OAuth to protokół autoryzacji zbudowany na bazie HTTP pozwalający
31 aplikacjom na bezpieczny dosŧęp do danych bez potrzeby przechowywania
32 nazw użytkownika czy haseł.
33
34 To rozszerzenie ma w PECL status: %{status}.
35
36 %prep
37 %setup -qc
38 mv %{modname}-%{version}/* .
39 find -newer LICENSE -o -print | xargs touch --reference %{SOURCE0}
40
41 %build
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{_examplesdir}/%{name}-%{version}}
49
50 %{__make} install \
51         INSTALL_ROOT=$RPM_BUILD_ROOT \
52         EXTENSION_DIR=%{php_extensiondir}
53 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
54 ; Enable %{modname} extension module
55 extension=%{modname}.so
56 EOF
57
58 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 %php_webserver_restart
65
66 %postun
67 if [ "$1" = 0 ]; then
68         %php_webserver_restart
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc LICENSE
74 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
75 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
76 %{_examplesdir}/%{name}-%{version}
This page took 0.0696059999999999 seconds and 2 git commands to generate.