]> git.pld-linux.org Git - packages/php-pecl-mono.git/blob - php-pecl-mono.spec
5f4866c3e718202a391fc0fb0d6c76db395c9e6c
[packages/php-pecl-mono.git] / php-pecl-mono.spec
1 # TODO
2 # - doesn't compile
3 #  - php-pecl-mono-0.7/mono-0.7/php_mono.c:33:37: mono/metadata/tabledefs.h: No such file or directory
4 # - package examples into examplesdir
5 %define         _modname        mono
6 %define         _status         beta
7 Summary:        %{_modname} - allows you to access .NET assemblies from PHP
8 Summary(pl.UTF-8):      %{_modname} - pozwala na dostęp do wstawek .NET w PHP
9 Name:           php-pecl-%{_modname}
10 Version:        0.7
11 Release:        0.2
12 License:        PHP 3.01
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
15 # Source0-md5:  23639443898018a743250a62b1873a89
16 URL:            http://pecl.php.net/package/mono/
17 BuildRequires:  mono-devel
18 BuildRequires:  php-devel >= 3:5.0.0
19 BuildRequires:  rpmbuild(macros) >= 1.344
20 %{?requires_php_extension}
21 Requires:       php-common >= 4:5.0.4
22 Obsoletes:      php-mono
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A C extension that interfaces with the mono library to allow access to
27 .NET assemblies.
28
29 In PECL status of this package is: %{_status}.
30
31 %description -l pl.UTF-8
32 Rozszerzenie w C, które jest interfejsem do biblioteki mono,
33 pozwalającym na dostęp do wstawek w .NET.
34
35 To rozszerzenie ma w PECL status: %{_status}.
36
37 %prep
38 %setup -q -c
39
40 %build
41 cd %{_modname}-%{version}
42 phpize
43 %configure \
44         --with-%{_modname}
45
46 %{__make} \
47 CPPFLAGS="-DHAVE_CONFIG_H -I/usr/X11R6/include/X11/" \
48         CFLAGS_CLEAN="%{rpmcflags}"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
53
54 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
55 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
56 ; Enable %{_modname} extension module
57 extension=%{_modname}.so
58 EOF
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 %php_webserver_restart
65
66 %postun
67 if [ "$1" = 0 ]; then
68         %php_webserver_restart
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc %{_modname}-%{version}/examples/{*.php,*.jpg,*.gif}
74 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
75 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.050942 seconds and 2 git commands to generate.