]> git.pld-linux.org Git - packages/php-pecl-mono.git/blob - php-pecl-mono.spec
support building for multiple php versions
[packages/php-pecl-mono.git] / php-pecl-mono.spec
1 # TODO
2 # - doesn't compile
3 #  - php-pecl-mono-0.7/mono-0.7/php_mono.c:33:37: mono/metadata/tabledefs.h: No such file or directory
4 #  - add missing -I: php52-pecl-mono-0.7/php_mono.h:25:26: fatal error: mono/jit/jit.h: No such file or directory
5 # - package examples into examplesdir
6 %define         php_name        php%{?php_suffix}
7 %define         modname mono
8 %define         status          beta
9 Summary:        %{modname} - allows you to access .NET assemblies from PHP
10 Summary(pl.UTF-8):      %{modname} - pozwala na dostęp do wstawek .NET w PHP
11 Name:           %{php_name}-pecl-%{modname}
12 Version:        0.7
13 Release:        0.2
14 License:        PHP 3.01
15 Group:          Development/Languages/PHP
16 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
17 # Source0-md5:  23639443898018a743250a62b1873a89
18 URL:            http://pecl.php.net/package/mono/
19 BuildRequires:  mono-devel
20 BuildRequires:  %{php_name}-devel >= 3:5.0.0
21 BuildRequires:  rpmbuild(macros) >= 1.650
22 %{?requires_php_extension}
23 Requires:       php-common >= 4:5.0.4
24 Obsoletes:      php-mono
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 A C extension that interfaces with the mono library to allow access to
29 .NET assemblies.
30
31 In PECL status of this package is: %{status}.
32
33 %description -l pl.UTF-8
34 Rozszerzenie w C, które jest interfejsem do biblioteki mono,
35 pozwalającym na dostęp do wstawek w .NET.
36
37 To rozszerzenie ma w PECL status: %{status}.
38
39 %prep
40 %setup -qc
41 mv %{modname}-%{version}/* .
42
43 %build
44 phpize
45 %configure \
46         --with-%{modname}
47
48 %{__make} \
49         CPPFLAGS="-DHAVE_CONFIG_H -I/usr/X11R6/include/X11/" \
50         CFLAGS_CLEAN="%{rpmcflags}"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
55
56 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
57 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
58 ; Enable %{modname} extension module
59 extension=%{modname}.so
60 EOF
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %php_webserver_restart
67
68 %postun
69 if [ "$1" = 0 ]; then
70         %php_webserver_restart
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc examples/{*.php,*.jpg,*.gif}
76 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
77 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.090559 seconds and 3 git commands to generate.