]> git.pld-linux.org Git - packages/php-pecl-memcache.git/blob - php-pecl-memcache.spec
simple module load test
[packages/php-pecl-memcache.git] / php-pecl-memcache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname memcache
7 %define         php_min_version 5.0.0
8 %include        /usr/lib/rpm/macros.php
9 Summary:        %{modname} - a memcached extension
10 Summary(pl.UTF-8):      %{modname} - rozszerzenie memcached
11 Name:           %{php_name}-pecl-%{modname}
12 Version:        3.0.9
13 Release:        1
14 License:        PHP 3.01
15 Group:          Development/Languages/PHP
16 #Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
17 Source0:        https://github.com/websupport-sk/pecl-memcache/archive/NON_BLOCKING_IO_php7.tar.gz
18 # Source0-md5:  7751d8191302a726449d7c6506b8783d
19 Source1:        %{modname}.ini
20 Source2:        %{modname}-apache.conf
21 Source3:        %{modname}-lighttpd.conf
22 Source4:        config.php
23 Patch0:         %{modname}-webapp.patch
24 URL:            http://pecl.php.net/package/memcache/
25 BuildRequires:  %{php_name}-devel >= 3:5.0.0
26 BuildRequires:  %{php_name}-xml
27 BuildRequires:  php-packagexml2cl
28 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
29 BuildRequires:  rpmbuild(macros) >= 1.650
30 %if %{with tests}
31 BuildRequires:  %{php_name}-cli
32 BuildRequires:  %{php_name}-session
33 %endif
34 %{?requires_php_extension}
35 Requires:       %{php_name}-session
36 Requires:       %{php_name}-zlib
37 Suggests:       memcached
38 Provides:       php(memcache) = %{version}
39 Obsoletes:      php-pecl-memcache < 3.0.8-5
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _webapps        /etc/webapps
43 %define         _webapp         %{modname}
44 %define         _sysconfdir     %{_webapps}/%{_webapp}
45 %define         _appdir         %{_datadir}/%{_webapp}
46
47 # bad depsolver
48 %define         _noautopear     pear
49
50 # put it together for rpmbuild
51 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
52
53 %description
54 Memcached is a caching daemon designed especially for dynamic web
55 applications to decrease database load by storing objects in memory.
56
57 This extension allows you to work with memcached through handy OO and
58 procedural interfaces.
59
60 %description -l pl.UTF-8
61 Memcached to zaprojektowany dla dynamicznych aplikacji internetowych
62 daemon cachujący mający za zadanie zmniejszenie obciążenia bazy danych
63 przez przechowywanie w pamięci obiektów.
64
65 To rozszerzenie umożliwia pracę z memcached za pomocą poręcznego
66 zorientowanego obiektowo (oraz przez procedury) interfejsu.
67
68 %package web
69 Summary:        Web interface for memcache
70 Group:          Libraries
71 # does not require extension itself
72 Requires:       php(core) >= %{php_min_version}
73 Requires:       php(date)
74 Requires:       php(gd)
75 Requires:       php(pcre)
76 Requires:       webapps
77 Requires:       webserver(php) >= 5.0
78 %if "%{_rpmversion}" >= "5"
79 BuildArch:      noarch
80 %endif
81
82 %description web
83 Via this web interface script you can manage and view statistics of
84 memcache.
85
86 %prep
87 %setup -qc
88 mv pecl-%{modname}-*/{.??*,*} .
89 %patch0 -p1
90
91 %build
92 packagexml2cl package.xml > ChangeLog
93 phpize
94 %configure \
95         --with-zlib-dir=/usr
96 %{__make}
97
98 %if %{with tests}
99 # simple module load test
100 %{__php} -n -q \
101         -d extension_dir=modules \
102         -d extension=%{php_extensiondir}/session.so \
103         -d extension=%{modname}.so \
104         -m > modules.log
105 grep %{modname} modules.log
106 %endif
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
111 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
112 # we use "session_" prefix in inifile to get loader *after* session extension
113 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/session_%{modname}.ini
114 cp -p example.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
115
116 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
117 cp -p memcache.php $RPM_BUILD_ROOT%{_appdir}
118 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
119 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
120 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
121 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 %php_webserver_restart
128
129 %postun
130 if [ "$1" = 0 ]; then
131         %php_webserver_restart
132 fi
133
134 %triggerpostun -- %{name} < 3.0.4-2
135 if [ -f %{php_sysconfdir}/conf.d/%{modname}.ini.rpmsave ]; then
136         echo >&2 "Restoring old config: %{modname}.ini.rpmsave -> session_%{modname}.ini in %{php_sysconfdir}/conf.d"
137         cp -f %{php_sysconfdir}/conf.d/session_%{modname}.ini{,.rpmnew}
138         mv -f %{php_sysconfdir}/conf.d/{%{modname}.ini.rpmsave,session_%{modname}.ini}
139         %php_webserver_restart
140 fi
141
142 %triggerin web -- apache1 < 1.3.37-3, apache1-base
143 %webapp_register apache %{_webapp}
144
145 %triggerun web -- apache1 < 1.3.37-3, apache1-base
146 %webapp_unregister apache %{_webapp}
147
148 %triggerin web -- apache < 2.2.0, apache-base
149 %webapp_register httpd %{_webapp}
150
151 %triggerun web -- apache < 2.2.0, apache-base
152 %webapp_unregister httpd %{_webapp}
153
154 %triggerin web -- lighttpd
155 %webapp_register lighttpd %{_webapp}
156
157 %triggerun web -- lighttpd
158 %webapp_unregister lighttpd %{_webapp}
159
160 %files
161 %defattr(644,root,root,755)
162 %doc CREDITS README ChangeLog
163 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/session_%{modname}.ini
164 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
165 %{_examplesdir}/%{name}-%{version}
166
167 %files web
168 %defattr(644,root,root,755)
169 %dir %attr(750,root,http) %{_sysconfdir}
170 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
171 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
172 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
173 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
174 %{_appdir}
This page took 0.107484 seconds and 3 git commands to generate.