]> git.pld-linux.org Git - packages/php-pecl-mailparse.git/blob - php-pecl-mailparse.spec
- obsolete old php name
[packages/php-pecl-mailparse.git] / php-pecl-mailparse.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname mailparse
3 %define         status          stable
4 Summary:        %{modname} - email message manipulation
5 Summary(pl.UTF-8):      %{modname} - obrabianie wiadomości E-mail
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        2.1.6
8 Release:        6
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  0f84e1da1d074a4915a9bcfe2319ce84
13 URL:            http://pecl.php.net/package/mailparse/
14 BuildRequires:  %{php_name}-devel >= 4:5.2.0-7.2
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Provides:       php(%{modname}) = %{version}
18 Obsoletes:      php-pecl-mailparse < 2.1.6-5
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Mailparse is an extension for parsing and working with email messages.
23 It can deal with rfc822 and rfc2045 (MIME) compliant messages.
24
25 In PECL status of this package is: %{status}.
26
27 %description -l pl.UTF-8
28 Mailparse to rozszerzenie do analizy i pracy z wiadomościami poczty
29 elektronicznej. Radzi sobie z wiadomościami zgodnymi z RFC822 oraz
30 RFC2024 (MIME).
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure \
41         --with-%{modname}=%{_prefix}/X11R6/include/X11/
42
43 %{__make} CPPFLAGS="-DHAVE_CONFIG_H -I%{_prefix}/X11R6/include/X11"
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
48
49 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
50 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
51 ; Enable %{modname} extension module
52 extension=%{modname}.so
53 EOF
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %php_webserver_restart
60
61 %postun
62 if [ "$1" = 0 ]; then
63         %php_webserver_restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc CREDITS
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.051289 seconds and 3 git commands to generate.