]> git.pld-linux.org Git - packages/php-pecl-lzf.git/blob - php-pecl-lzf.spec
d3bd7afa4b7421a33e4035d33827df6602cb9851
[packages/php-pecl-lzf.git] / php-pecl-lzf.spec
1 # TODO
2 # - use system liblzf
3 %define         php_name        php%{?php_suffix}
4 %define         modname lzf
5 %define         modname_c       LZF
6 %define         status          stable
7 Summary:        %{modname} - (de)compression
8 Summary(pl.UTF-8):      %{modname} - (de)kompresja
9 Name:           %{php_name}-pecl-%{modname}
10 Version:        1.5.2
11 Release:        5
12 License:        PHP 3.01
13 Group:          Development/Languages/PHP
14 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
15 # Source0-md5:  d0313d93783cd11c8e038abfcf1b4f91
16 URL:            http://pecl.php.net/package/LZF/
17 BuildRequires:  %{php_name}-devel >= 3:5.0.0
18 BuildRequires:  rpmbuild(macros) >= 1.650
19 %{?requires_php_extension}
20 Requires:       php(core) >= 5.0.4
21 Obsoletes:      php-pear-%{modname}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This package handles LZF de/compression.
26
27 In PECL status of this package is: %{status}.
28
29 %description -l pl.UTF-8
30 Ten pakiet dostarczaj obsługę (de)kompresji archiwów LZF.
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -q -c
36
37 %build
38 cd %{modname_c}-%{version}
39 phpize
40 %configure \
41         --enable-lzf
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
47
48 install %{modname_c}-%{version}/modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50 ; Enable %{modname} extension module
51 extension=%{modname}.so
52 EOF
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %php_webserver_restart
59
60 %postun
61 if [ "$1" = 0 ]; then
62         %php_webserver_restart
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
68 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.059198 seconds and 2 git commands to generate.