]> git.pld-linux.org Git - packages/php-pecl-inotify.git/blob - php-pecl-inotify.spec
9d97a63bc84c9970e12c52b4f14335e893e095e8
[packages/php-pecl-inotify.git] / php-pecl-inotify.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname inotify
3 %define         status          stable
4 Summary:        %{modname} - php bindings
5 Summary(pl.UTF-8):      %{modname} - dowiÄ…zania php
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.1.6
8 Release:        4
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  c7d837c4837d8132c451c6ab37ef917e
13 URL:            http://pecl.php.net/package/inotify/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  glibc-devel >= 6:2.3.6-19
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The inotify extension allows to use inotify functions in a PHP script.
24
25 In PECL status of this extension is: %{status}.
26
27 %description -l pl.UTF-8
28 Rozszerzenie inotify pozwala na skorzystanie z funkcji inotify w
29 skrypcie PHP.
30
31 To rozszerzenie ma w PECL status: %{status}.
32
33 %prep
34 %setup -qc
35 mv %{modname}-%{version}/* .
36
37 %build
38 phpize
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
45
46 %{__make} install \
47         INSTALL_ROOT=$RPM_BUILD_ROOT \
48         EXTENSION_DIR=%{php_extensiondir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50 ; Enable %{modname} extension module
51 extension=%{modname}.so
52 EOF
53
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 cp -p inotify.php tail.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %php_webserver_restart
62
63 %postun
64 if [ "$1" = 0 ]; then
65         %php_webserver_restart
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CREDITS EXPERIMENTAL README
71 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
72 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
73 %{_examplesdir}/%{name}-%{version}
This page took 0.057926 seconds and 2 git commands to generate.