]> git.pld-linux.org Git - packages/php-pecl-hidef.git/blob - php-pecl-hidef.spec
- php 5.5 rebuild
[packages/php-pecl-hidef.git] / php-pecl-hidef.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname hidef
3 %define         status          stable
4 Summary:        %{modname} - Constants for real
5 Summary(pl.UTF-8):      %{modname} - mechanizm definiowana stałych
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.1.13
8 Release:        3
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  41cec59636c38abfd0cf15011a1184f4
13 URL:            http://pecl.php.net/package/hidef/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Provides:       php(%{modname}) = %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Allow definition of user defined constants in simple ini files, which
23 are then processed like internal constants, without any of the usual
24 performance penalties.
25
26 In PECL status of this extension is: %{status}.
27
28 %description -l pl.UTF-8
29 Rozszerzenie to pozwala na zdefiniowanie stałych w prostym pliku ini.
30 Stałe te są później przetwarzane tak jak wewnętrzne stałe PHP, bez
31 typowych spowolnień wydajności.
32
33 To rozszerzenie ma w PECL status: %{status}.
34
35 %prep
36 %setup -qc
37 mv %{modname}-%{version}/* .
38
39 %build
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
47
48 %{__make} install \
49         EXTENSION_DIR=%{php_extensiondir} \
50         INSTALL_ROOT=$RPM_BUILD_ROOT
51 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
52 ; Enable %{modname} extension module
53 extension=%{modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc INSTALL CREDITS
70 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
71 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.058234 seconds and 3 git commands to generate.