]> git.pld-linux.org Git - packages/php-pecl-hash.git/blob - php-pecl-hash.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-hash.git] / php-pecl-hash.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname hash
3 %define         status          stable
4 Summary:        %{modname} - HASH Message Digest Framework
5 Summary(pl.UTF-8):      %{modname} - implementacja popularnych funkcji skrótu
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.5
8 Release:        2
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  cb19f4ee392b05776788e54b51f98c83
13 URL:            http://pecl.php.net/package/hash/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Provides:       php(%{modname}) = %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Native implementations of common message digest algorithms using a
23 generic factory method.
24
25 In PECL status of this extension is: %{status}.
26
27 %description -l pl.UTF-8
28 Natywne implementacje popularnych algorytmów skrótu.
29
30 To rozszerzenie ma w PECL status: %{status}.
31
32 %prep
33 %setup -qc
34 mv %{modname}-%{version}/* .
35
36 %build
37 phpize
38 %configure
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
44 %{__make} install \
45         INSTALL_ROOT=$RPM_BUILD_ROOT \
46         EXTENSION_DIR=%{php_extensiondir}
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc README
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.061368 seconds and 3 git commands to generate.