]> git.pld-linux.org Git - packages/php-pecl-haru.git/blob - php-pecl-haru.spec
- php 5.5 rebuild
[packages/php-pecl-haru.git] / php-pecl-haru.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname haru
3 %define         status          stable
4 Summary:        %{modname} - Haru PDF functions
5 Summary(pl.UTF-8):      %{modname} - funkcje PDF haru
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.4
8 Release:        3
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  be91eed4a46c7067d7877bbe8b64ac23
13 URL:            http://pecl.php.net/package/haru/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  libharu-devel >= 2.0.8-2
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.0.4
19 Provides:       php(%{modname}) = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This extensions allows you to create PDF documents using the Haru Free
24 PDF Library.
25
26 In PECL status of this extension is: %{status}.
27
28 %description -l pl.UTF-8
29 Rozszerzenie to pozwala na tworzenie dokumentów PDF przy użyciu
30 biblioteki Haru.
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -q -c
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
46
47 %{__make} install \
48         INSTALL_ROOT=$RPM_BUILD_ROOT \
49         EXTENSION_DIR=%{php_extensiondir}
50 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
51 ; Enable %{modname} extension module
52 extension=%{modname}.so
53 EOF
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %php_webserver_restart
60
61 %postun
62 if [ "$1" = 0 ]; then
63         %php_webserver_restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc CREDITS
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.092802 seconds and 3 git commands to generate.