]> git.pld-linux.org Git - packages/php-pecl-dbx.git/blob - php-pecl-dbx.spec
- php 5.5 rebuild
[packages/php-pecl-dbx.git] / php-pecl-dbx.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname dbx
3 %define         status          stable
4 Summary:        %{modname} - database abstraction functions
5 Summary(pl.UTF-8):      %{modname} - funkcje abstrakcji baz danych
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.1.2
8 Release:        3
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  8cac1af119e6afa519853bfd3a911bbb
13 URL:            http://pecl.php.net/package/dbx/
14 BuildRequires:  %{php_name}-devel >= 4:5.0.4
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Obsoletes:      php-dbx
18 Provides:       php(%{modname}) = %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The dbx module is a database abstraction layer. The dbx functions
23 allow you to access all supported databases using a single calling
24 convention. The dbx-functions themselves do not interface directly to
25 the databases, but interface to the modules that are used to support
26 these databases.
27
28 The currently supported databases are MySQL, ODBC, Oracle (oci8), MS
29 SQL Server, PostgreSQL, FrontBase, Sybase-CT and SQLite.
30
31 In PECL status of this extension is: %{status}.
32
33 %description -l pl.UTF-8
34 Moduł dbx to warstwa abstrakcji baz danych. Funkcje dbx pozwalają na
35 dostęp do wspieranych baz danych przy użyciu spójnej konwencji.
36 Funkcje dbx jako takie nie są bezpośrednim interfejsem do bazy danych,
37 ale interfejsem do modułów do obsługi baz danych.
38
39 Aktualnie wspierane bazy danych to MySQL, ODBC, Oracle (oci8), MS SQL
40 Server, PostgreSQL, FrontBase, Sybase-CT oraz SQLite.
41
42 To rozszerzenie ma w PECL status: %{status}.
43
44 %prep
45 %setup -qc
46 mv %{modname}-*/* .
47
48 %build
49 phpize
50 %configure
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
56 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
57 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
58 ; Enable %{modname} extension module
59 extension=%{modname}.so
60 EOF
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post
66 %php_webserver_restart
67
68 %postun
69 if [ "$1" = 0 ]; then
70         %php_webserver_restart
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc CREDITS
76 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
77 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.032587 seconds and 3 git commands to generate.