]> git.pld-linux.org Git - packages/php-pecl-crack.git/blob - php-pecl-crack.spec
- BuildRequires: libcrack-devel
[packages/php-pecl-crack.git] / php-pecl-crack.spec
1 %define         _modname        crack
2 %define         _status         stable
3
4 Summary:        %{_modname} - checks if password is vulnerable to dictionary attacks
5 Summary(pl):    %{_modname} - sprawdzanie czy has³o jest podatne na ataki s³ownikowe
6 Name:           php-pecl-%{_modname}
7 Version:        0.2
8 Release:        1
9 License:        Artistic
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  0fbce1787086f21683f0ba5115902223
13 Patch0:         %{name}-m4_fixes.patch
14 URL:            http://pecl.php.net/package/crack/
15 BuildRequires:  libcrack-devel
16 BuildRequires:  libtool
17 BuildRequires:  php-devel >= 3:5.0.0
18 Requires:       php-common >= 3:5.0.0
19 Obsoletes:      php-crack
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sysconfdir     /etc/php
24 %define         extensionsdir   %{_libdir}/php
25
26 %description
27 This package provides an interface to the cracklib (libcrack)
28 libraries that come standard on most unix-like distributions. This
29 allows you to check passwords against dictionaries of words to ensure
30 some minimal level of password security.
31
32 In PECL status of this extension is: %{_status}.
33
34 %description -l pl
35 Ten pakiet dostarcza interfejsu do bibliotek cracklib (libcrack),
36 dostarczanych z wiêkszo¶ci± dystrybucji uniksopodobnych. Pozwala to
37 na porównanie hase³ wzglêdem s³owników celem zapewnienia minimalnego
38 poziomu bezpieczeñstwa.
39
40 To rozszerzenie ma w PECL status: %{_status}.
41
42 %prep
43 %setup -q -c
44 %patch0 -p1
45
46 %build
47 cd %{_modname}-%{version}
48 phpize
49 %configure
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{extensionsdir}
55
56 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
63
64 %preun
65 if [ "$1" = "0" ]; then
66         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
72 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.059929 seconds and 3 git commands to generate.