]> git.pld-linux.org Git - packages/php-pecl-bitset.git/blob - php-pecl-bitset.spec
- obsolete old php name
[packages/php-pecl-bitset.git] / php-pecl-bitset.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname bitset
3 Summary:        %{modname} - managing sets of bits
4 Summary(pl.UTF-8):      %{modname} - obróbka zbiorów bitów
5 Name:           %{php_name}-pecl-%{modname}
6 Version:        2.0
7 Release:        4
8 License:        PHP 3.01
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
11 # Source0-md5:  377e3e3ce071ac10908df8ccdd4a5a26
12 URL:            http://pecl.php.net/package/bitset/
13 BuildRequires:  %{php_name}-devel >= 3:5.3.0
14 BuildRequires:  rpmbuild(macros) >= 1.650
15 %{?requires_php_extension}
16 Provides:       php(%{modname}) = %{version}
17 Obsoletes:      php-pecl-bitset < 2.0-3
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The BitSet library assists by providing a mechanism to manage sets of
22 bits. This provides a similar API (object-based) to java.util.BitSet
23 with some PHP-specific flavoring.
24
25 The original functions provided under 1.0 are still available, though
26 deprecated as of 2.0 and will be removed under 3.0.
27
28 IMPORTANT: Versions 2.0 and higher of this extension require PHP 5.3+
29
30 %description -l pl.UTF-8
31 Rozszerzenie to jest biblioteką do zarządzania zbiorami bitów w
32 rozumieniu Teorii Zbiorów.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CREDITS README
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.078165 seconds and 3 git commands to generate.