]> git.pld-linux.org Git - packages/php-pecl-archive.git/blob - php-pecl-archive.spec
58bb65e404f61f25cabac919c5a32ed791a8601d
[packages/php-pecl-archive.git] / php-pecl-archive.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname archive
3 %define         status          beta
4 Summary:        %{modname} - manipulate tar/cpio archives
5 Summary(pl.UTF-8):      %{modname} - obróbka archiwów tar/cpio
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.2
8 Release:        16
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  1b121440b2c460b2a1af46e31f23e46e
13 Patch0:         php-pecl-%{modname}-php52.patch
14 URL:            http://pecl.php.net/package/archive/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.0
16 BuildRequires:  libarchive-devel
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 Requires:       php(core) >= 5.0.4
20 Obsoletes:      php-pear-%{modname}
21 Provides:       php(%{modname}) = %{version}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 archive extension allows to read and write tar and cpio archives using
26 libarchive.
27
28 In PECL status of this extension is: %{status}.
29
30 %description -l pl.UTF-8
31 Rozszerzenie archive pozwala na odczyt i zapis archiwów tar oraz cpio
32 przy użyciu biblioteki libarchive.
33
34 To rozszerzenie ma w PECL status: %{status}.
35
36 %prep
37 %setup -qc
38 mv %{modname}-%{version}/* .
39 %patch0 -p0
40
41 %build
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
49 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
50 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
51 ; Enable %{modname} extension module
52 extension=%{modname}.so
53 EOF
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %php_webserver_restart
60
61 %postun
62 if [ "$1" = 0 ]; then
63         %php_webserver_restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc API.txt CREDITS tests
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.058933 seconds and 2 git commands to generate.