]> git.pld-linux.org Git - packages/php-pear-System_Mount.git/blob - php-pear-System_Mount.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/php-pear-System_Mount.git] / php-pear-System_Mount.spec
1 %define         _status         stable
2 %define         _pearname       System_Mount
3 Summary:        %{_pearname} - mount and unmount devices in fstab
4 Summary(pl.UTF-8):      %{_pearname} - montowanie i odmontowywanie urządzeń z fstab
5 Name:           php-pear-%{_pearname}
6 Version:        1.0.1
7 Release:        1
8 License:        PHP 3.0
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
11 # Source0-md5:  c4d586a8cc91e056cf311ae89c9c1341
12 URL:            http://pear.php.net/package/System_Mount/
13 BuildRequires:  php-pear-PEAR >= 1:1.4.0-0.b1
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.571
16 Requires:       php-pear
17 Requires:       php-pear-File_Fstab >= 2.0.0-0.beta1
18 Requires:       php-pear-System_Command
19 Suggests:       php-pear-File
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # exclude optional dependencies
24 %define         _noautoreq      pear(File.*)
25
26 %description
27 System_Mount provides a simple interface to deal with mounting and
28 unmounting devices listed in the system's fstab.
29
30 Features:
31 - Very compact, easy-to-read code, based on File_Fstab,
32 - Examines mount options to determine if a device can be mounted or
33   not,
34 - Extremely easy to use,
35 - Fully documented with PHPDoc.
36
37 In PEAR status of this package is: %{_status}.
38
39 %description -l pl.UTF-8
40 System_Mount dostarcza prostego interfejsu do radzenia sobie z
41 montowaniem i odmontowywaniem urządzeń wpisanych w pliku fstab.
42
43 Cechy:
44 - Bardzo prosty, czytelny kod bazowany na File-Fstab,
45 - Bada opcje mount w celu stwierdzenia czy urządzenie może być
46   zamontowane lub nie,
47 - Niewiarygodnie łatwy w użyciu,
48 - W pełni udokumentowany za pomocą PHPDoc.
49
50 Ta klasa ma w PEAR status: %{_status}.
51
52 %prep
53 %pear_package_setup
54
55 install -d examples
56 mv docs/System_Mount/docs/example.php examples
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{php_pear_dir}
61 %pear_package_install
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post -p <lua>
70 %pear_package_print_optionalpackages
71
72 %files
73 %defattr(644,root,root,755)
74 %doc install.log optional-packages.txt
75 %doc docs/%{_pearname}/*
76 %{php_pear_dir}/.registry/*.reg
77 %{php_pear_dir}/System/Mount.php
78
79 %{_examplesdir}/%{name}-%{version}
This page took 0.109356 seconds and 3 git commands to generate.