]> git.pld-linux.org Git - packages/php-pear-PHP_Shell.git/blob - php-pear-PHP_Shell.spec
- use virtual php extension deps (to be independant of php version)
[packages/php-pear-PHP_Shell.git] / php-pear-PHP_Shell.spec
1 %define         status          alpha
2 %define         pearname        PHP_Shell
3 %include        /usr/lib/rpm/macros.php
4 Summary:        %{pearname} - an interactive PHP Shell like IPython
5 Summary(pl.UTF-8):      %{pearname} - interaktywna powłoka PHP podobna do IPythona
6 Name:           php-pear-%{pearname}
7 Version:        0.3.2
8 Release:        3
9 License:        MIT
10 Group:          Development/Languages/PHP
11 Source0:        http://pear.php.net/get/%{pearname}-%{version}.tgz
12 # Source0-md5:  ca73ede3157d3e2d8e745daa4439524d
13 URL:            http://pear.php.net/package/PHP_Shell/
14 BuildRequires:  php-pear-PEAR >= 1:1.4.0-0.b1
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.580
17 Requires:       php(core) >= 5.0.0
18 Requires:       php(readline)
19 Requires:       php(tokenizer)
20 Requires:       php-pear
21 Requires:       php-pear-PEAR-core >= 1:1.4
22 Obsoletes:      php-pear-PHP_Shell-tests
23 Obsoletes:      php-shell
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 PHP-based implementation of a interactive shell with history,
29 tab-completion, handling of fatal errors, debugging aid, ...
30
31 In PEAR status of this package is: %{status}.
32
33 %description -l pl.UTF-8
34 Oparta na PHP implementacja interaktywnej powłoki z historią,
35 dopełnianiem tabem, obsługą błędów krytycznych, pomocą przy usuwaniu
36 błędów...
37
38 Ta klasa ma w PEAR status: %{status}.
39
40 %prep
41 %pear_package_setup
42
43 mv docs/PHP_Shell/README .
44 mv .%{php_pear_dir}/examples .
45 mv .%{php_pear_dir}/data/PHP_Shell/scripts .
46 mv .%{php_pear_dir}/scripts/* scripts
47 %{__sed} -i -e '1i#!/usr/bin/php' scripts/php-shell-cmd.php
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{php_pear_dir},%{_bindir}}
52 %pear_package_install
53
54 install -p scripts/php-shell-cmd.php $RPM_BUILD_ROOT%{_bindir}/php-shell
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README
62 %attr(755,root,root) %{_bindir}/php-shell
63 %{php_pear_dir}/.registry/*.reg
64 %{php_pear_dir}/PHP/Shell.php
65 %{php_pear_dir}/PHP/Shell
This page took 0.086604 seconds and 3 git commands to generate.