]> git.pld-linux.org Git - packages/php-pear-PEAR.git/blob - php-pear-PEAR.spec
- updated to 1.4.0a10
[packages/php-pear-PEAR.git] / php-pear-PEAR.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PEAR
3 %define         _status         alpha
4 %define         _pearname       %{_class}
5
6 Summary:        %{_pearname} - main PHP PEAR class
7 Summary(pl):    %{_pearname} - podstawowa klasa dla PHP PEAR
8 Name:           php-pear-%{_pearname}
9 Version:        1.4.0
10 %define         _pre a10
11 Release:        0.%{_pre}.1
12 Epoch:          1
13 License:        PHP 3.0
14 Group:          Development/Languages/PHP
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}%{_pre}.tgz
16 # Source0-md5:  59ee4e0f5ce9cc1f5331e41f225a5e90
17 URL:            http://pear.php.net/package/PEAR/
18 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
19 BuildRequires:  sed >= 4.0.0
20 Requires:       php-pear
21 Obsoletes:      php-pear-PEAR-Command
22 Obsoletes:      php-pear-PEAR-Frontend-CLI
23 Obsoletes:      php-pear-PEAR-OS
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The PEAR package contains:
29 - the PEAR installer, for creating, distributing and installing packages
30 - the alpha-quality PEAR_Exception PHP5 error handling mechanism
31 - the beta-quality PEAR_ErrorStack advanced error handling mechanism
32 - the PEAR_Error error handling mechanism
33 - the OS_Guess class for retrieving info about the OS where PHP is running on
34 - the System class for quick handling of common operations with files and
35   directories
36 - the PEAR base class packages
37
38 In PEAR status of this package is: %{_status}.
39
40 %description -l pl
41 Pakiet PEAR zawiara:
42 - PEAR installer do tworzenia, dystrybucji i instalowania pakietów,
43 - mechanizm PEAR_Exception (w fazie alpha) do obs³ugi b³êdów PHP5,
44 - zaawansowany mechanizm PEAR_ErrorStack (w fazie beta) do obs³ugi b³êdów,
45 - mechanizm obs³ugi b³êdów PEAR_Error,
46 - klasê OS_Guess do pozyskiwania informacji na temat systemu operacyjnego,
47 - klasê System do szybkiej obs³ugi typowych operacji na plikach i
48   katalogach,
49 - podstawow± klasy PEAR.
50
51 Ta klasa ma w PEAR status: %{_status}.
52
53 %prep
54 %setup -q -c -n %{name}-%{version}%{_pre}
55
56 %build
57 # put proper paths
58 sed -i -e 's,@php_dir@,%{php_pear_dir},g' -e 's,@php_bin@,%{_bindir}/php,g' %{_pearname}-%{version}%{_pre}/scripts/*
59 # fix include path
60 sed -i -e 's,PEAR/PackageFile/Generator/v2/rw.php,PEAR/PackageFile/v2/rw.php,g' %{_pearname}-%{version}%{_pre}/PEAR/PackageFile/v2.php
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{php_pear_dir}/{%{_class}/{ChannelFile,Command,Downloader,Frontend,Installer/Role,PackageFile/{Generator,Parser,v2},Task,Validator},OS},%{_bindir}}
65
66 install %{_pearname}-%{version}%{_pre}/*.php $RPM_BUILD_ROOT%{php_pear_dir}
67 install %{_pearname}-%{version}%{_pre}/*.dtd $RPM_BUILD_ROOT%{php_pear_dir}
68 install %{_pearname}-%{version}%{_pre}/OS/*.php $RPM_BUILD_ROOT%{php_pear_dir}/OS
69 install %{_pearname}-%{version}%{_pre}/%{_class}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}
70 install %{_pearname}-%{version}%{_pre}/%{_class}/ChannelFile/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/ChannelFile
71 install %{_pearname}-%{version}%{_pre}/%{_class}/Command/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Command
72 install %{_pearname}-%{version}%{_pre}/%{_class}/Downloader/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Downloader
73 install %{_pearname}-%{version}%{_pre}/%{_class}/Frontend/CLI.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Frontend
74 install %{_pearname}-%{version}%{_pre}/%{_class}/Installer/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Installer
75 install %{_pearname}-%{version}%{_pre}/%{_class}/Installer/Role/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Installer/Role
76 install %{_pearname}-%{version}%{_pre}/%{_class}/PackageFile/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/PackageFile
77 install %{_pearname}-%{version}%{_pre}/%{_class}/PackageFile/Generator/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/PackageFile/Generator
78 install %{_pearname}-%{version}%{_pre}/%{_class}/PackageFile/Parser/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/PackageFile/Parser
79 install %{_pearname}-%{version}%{_pre}/%{_class}/PackageFile/v2/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/PackageFile/v2
80 install %{_pearname}-%{version}%{_pre}/%{_class}/Task/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Task
81 install %{_pearname}-%{version}%{_pre}/%{_class}/Validator/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/Validator
82 install %{_pearname}-%{version}%{_pre}/scripts/pearcmd.php $RPM_BUILD_ROOT%{php_pear_dir}
83 install %{_pearname}-%{version}%{_pre}/scripts/peclcmd.php $RPM_BUILD_ROOT%{php_pear_dir}
84 install %{_pearname}-%{version}%{_pre}/scripts/pear.sh $RPM_BUILD_ROOT%{_bindir}/pear
85 install %{_pearname}-%{version}%{_pre}/scripts/pecl.sh $RPM_BUILD_ROOT%{_bindir}/pecl
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %{_bindir}/*
93 %{php_pear_dir}/*
This page took 0.049118 seconds and 4 git commands to generate.