]> git.pld-linux.org Git - packages/php-pear-PEAR.git/blob - php-pear-PEAR.spec
- updated to 1.4.5
[packages/php-pear-PEAR.git] / php-pear-PEAR.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PEAR
3 %define         _status         stable
4 %define         _pearname       %{_class}
5
6 Summary:        %{_pearname} - main PHP PEAR class
7 Summary(pl):    %{_pearname} - podstawowa klasa dla PHP PEAR
8 Name:           php-pear-%{_pearname}
9 Version:        1.4.5
10 Release:        1
11 Epoch:          1
12 License:        PHP 3.0
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  be4300609e4d966a6d68d6ec95942180
16 Source1:        %{name}-template.spec
17 Patch0:         %{name}-memory.patch
18 Patch1:         %{name}-sysconfdir.patch
19 Patch2:         %{name}-rpmpkgname.patch
20 Patch3:         %{name}-rpmvars.patch
21 Patch4:         %{name}-cli.patch
22 Patch5:         %{name}-old-api.patch
23 URL:            http://pear.php.net/package/PEAR
24 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
25 BuildRequires:  php-cli
26 BuildRequires:  php-pear >= 4:1.0-6
27 Requires:       php-cli
28 Requires:       php-pcre
29 Requires:       php-pear >= 4:1.0-5.5
30 Requires:       php-pear-Archive_Tar >= 1.1
31 Requires:       php-pear-Console_Getopt >= 1.2
32 Requires:       php-pear-XML_RPC >= 1.4.0
33 Requires:       php-xml
34 Requires:       php-zlib
35 Requires:       %{name}-core = %{epoch}:%{version}-%{release}
36 Obsoletes:      php-pear-PEAR-Command
37 Obsoletes:      php-pear-PEAR-Frontend-CLI
38 Obsoletes:      php-pear-PEAR-OS
39 Conflicts:      php-pear-Archive_Tar = 1.3.0
40 Conflicts:      php-pear-PEAR_Frontend_Web < 0.5.0
41 Conflicts:      php-pear-PEAR_Frontend_Gtk < 0.4.0
42 BuildArch:      noarch
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _noautoreq      'pear(PEAR/FTP.php)' 'pear(Net/FTP.php)'
46
47 %description
48 The PEAR package contains:
49 - the PEAR installer, for creating, distributing and installing
50   packages
51 - the alpha-quality PEAR_Exception PHP5 error handling mechanism
52 - the beta-quality PEAR_ErrorStack advanced error handling mechanism
53 - the PEAR_Error error handling mechanism
54 - the OS_Guess class for retrieving info about the OS where PHP is
55   running on
56 - the System class for quick handling of common operations with files
57   and directories
58 - the PEAR base class packages
59
60 In PEAR status of this package is: %{_status}.
61
62 %description -l pl
63 Pakiet PEAR zawiara:
64 - PEAR installer do tworzenia, dystrybucji i instalowania pakietów,
65 - mechanizm PEAR_Exception (w fazie alpha) do obs³ugi b³êdów PHP5,
66 - zaawansowany mechanizm PEAR_ErrorStack (w fazie beta) do obs³ugi
67   b³êdów,
68 - mechanizm obs³ugi b³êdów PEAR_Error,
69 - klasê OS_Guess do pozyskiwania informacji na temat systemu
70   operacyjnego,
71 - klasê System do szybkiej obs³ugi typowych operacji na plikach i
72   katalogach,
73 - podstawow± klasy PEAR.
74
75 Ta klasa ma w PEAR status: %{_status}.
76
77 %package core
78 Summary:        PEAR core classes
79 Summary(pl):    G³ówne klasy PEAR-a
80 Group:          Development/Languages/PHP
81
82 %description core
83 This package includes PEAR core classes:
84 - PEAR class and PEAR_Error
85 - System
86 - OS_Guess
87 and classes for PHP 5:
88 - PEAR_ErrorStack and PEAR_Exception
89
90 %description core -l pl
91 Ten pakiet zawiera g³ówne klasy PEAR-a:
92 - klasê PEAR i PEAR_Error
93 - System
94 - OS_Gueass
95 oraz klasy dla PHP 5:
96 - PEAR_ErrorStack i PEAR_Exception
97
98 %prep
99 %pear_package_setup
100 %patch0 -p2
101 %patch1 -p1
102 %patch2 -p1
103 %patch3 -p1
104 %patch4 -p1
105 %patch5 -p1
106
107 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{php_pear_dir},%{_bindir}}
113
114 D=$(pwd)
115 pearcmd() {
116         php -d output_buffering=1 -d include_path=".:${D}%{php_pear_dir}" ${D}%{php_pear_dir}/pearcmd.php -c ${D}/pearrc "$@"
117 }
118 pearcmd config-set doc_dir %{_docdir} || exit
119 pearcmd config-set data_dir %{php_pear_dir}/data || exit
120 pearcmd config-set php_dir %{php_pear_dir} || exit
121 pearcmd config-set test_dir %{php_pear_dir}/tests || exit
122 pearcmd config-set sig_bin %{_bindir}/gpg || exit
123 cp $D/pearrc $RPM_BUILD_ROOT%{_sysconfdir}/pear.conf
124
125 %pear_package_install
126 cp -a ./%{_bindir}/* $RPM_BUILD_ROOT%{_bindir}
127
128 sed -e '/^\$''Log: /,$d' %{SOURCE1} > $RPM_BUILD_ROOT%{php_pear_dir}/data/%{_class}/template.spec
129 echo '$''Log: $' >> $RPM_BUILD_ROOT%{php_pear_dir}/data/%{_class}/template.spec
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc install.log
137 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pear.conf
138 %attr(755,root,root) %{_bindir}/*
139 %{php_pear_dir}/.registry/*.reg
140 %{php_pear_dir}/pearcmd.php
141 %{php_pear_dir}/peclcmd.php
142 %{php_pear_dir}/PEAR/[!CE]*
143 %{php_pear_dir}/PEAR/ChannelFile*
144 %{php_pear_dir}/PEAR/Command*
145 %{php_pear_dir}/PEAR/Config.php
146 %{php_pear_dir}/PEAR/Common.php
147
148 %{php_pear_dir}/data/*
149
150 %files core
151 %defattr(644,root,root,755)
152 %{php_pear_dir}/PEAR.php
153 %{php_pear_dir}/System.php
154 %{php_pear_dir}/OS
155 %dir %{php_pear_dir}/PEAR
156 %{php_pear_dir}/PEAR/ErrorStack.php
157 %{php_pear_dir}/PEAR/Exception.php
This page took 0.080733 seconds and 4 git commands to generate.