]> git.pld-linux.org Git - packages/php-pear-PEAR.git/blob - php-pear-PEAR.spec
- rel 3
[packages/php-pear-PEAR.git] / php-pear-PEAR.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PEAR
3 %define         _status         stable
4 %define         _pearname       %{_class}
5
6 Summary:        %{_pearname} - main PHP PEAR class
7 Summary(pl):    %{_pearname} - podstawowa klasa dla PHP PEAR
8 Name:           php-pear-%{_pearname}
9 Version:        1.4.1
10 Release:        3
11 Epoch:          1
12 License:        PHP 3.0
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  6b39c590203d046f55f207c6c5a7cd18
16 Source1:        %{name}-template.spec
17 Patch0:         %{name}-memory.patch
18 Patch1:         %{name}-sysconfdir.patch
19 Patch2:         %{name}-rpmpkgname.patch
20 Patch3:         %{name}-rpmvars.patch
21 Patch4:         http://glen.alkohol.ee/pld/PEAR-makerpm1.patch
22 Patch5:         %{name}-cli.patch
23 URL:            http://pear.php.net/package/PEAR
24 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
25 BuildRequires:  php-pear >= 4:1.0-6
26 Requires:       php-cli
27 Requires:       php-pcre
28 Requires:       php-pear >= 4:1.0-5.5
29 Requires:       php-pear-Archive_Tar >= 1.1
30 Requires:       php-pear-Console_Getopt >= 1.2
31 Requires:       php-pear-XML_RPC >= 1.4.0
32 Obsoletes:      php-pear-PEAR-Command
33 Obsoletes:      php-pear-PEAR-Frontend-CLI
34 Obsoletes:      php-pear-PEAR-OS
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreq      'pear(PEAR/FTP.php)' 'pear(Net/FTP.php)'
39
40 %description
41 The PEAR package contains:
42 - the PEAR installer, for creating, distributing and installing
43   packages
44 - the alpha-quality PEAR_Exception PHP5 error handling mechanism
45 - the beta-quality PEAR_ErrorStack advanced error handling mechanism
46 - the PEAR_Error error handling mechanism
47 - the OS_Guess class for retrieving info about the OS where PHP is
48   running on
49 - the System class for quick handling of common operations with files
50   and directories
51 - the PEAR base class packages
52
53 In PEAR status of this package is: %{_status}.
54
55 %description -l pl
56 Pakiet PEAR zawiara:
57 - PEAR installer do tworzenia, dystrybucji i instalowania pakietów,
58 - mechanizm PEAR_Exception (w fazie alpha) do obs³ugi b³êdów PHP5,
59 - zaawansowany mechanizm PEAR_ErrorStack (w fazie beta) do obs³ugi
60   b³êdów,
61 - mechanizm obs³ugi b³êdów PEAR_Error,
62 - klasê OS_Guess do pozyskiwania informacji na temat systemu
63   operacyjnego,
64 - klasê System do szybkiej obs³ugi typowych operacji na plikach i
65   katalogach,
66 - podstawow± klasy PEAR.
67
68 Ta klasa ma w PEAR status: %{_status}.
69
70 %prep
71 %pear_package_setup
72 %patch0 -p2
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch5 -p1
77 cd ./%{php_pear_dir}
78 %patch4 -p1
79
80 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{php_pear_dir},%{_bindir}}
86
87 D=$(pwd)
88 pearcmd() {
89         php -d output_buffering=1 -d include_path=".:${D}%{php_pear_dir}" ${D}%{php_pear_dir}/pearcmd.php -c ${D}/pearrc "$@"
90 }
91 pearcmd config-set doc_dir %{_docdir} || exit
92 pearcmd config-set data_dir %{php_pear_dir}/data || exit
93 pearcmd config-set php_dir %{php_pear_dir} || exit
94 pearcmd config-set test_dir %{php_pear_dir}/tests || exit
95 pearcmd config-set sig_bin %{_bindir}/gpg || exit
96 cp $D/pearrc $RPM_BUILD_ROOT%{_sysconfdir}/pear.conf
97
98 %pear_package_install
99 cp -a ./%{_bindir}/* $RPM_BUILD_ROOT%{_bindir}
100
101 sed -e '/^\$''Log: /,$d' %{SOURCE1} > $RPM_BUILD_ROOT%{php_pear_dir}/data/%{_class}/template.spec
102 echo '$''Log: $' >> $RPM_BUILD_ROOT%{php_pear_dir}/data/%{_class}/template.spec
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc install.log
110 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pear.conf
111 %attr(755,root,root) %{_bindir}/*
112 %{php_pear_dir}/.registry/*.reg
113 %{php_pear_dir}/*.php
114 %{php_pear_dir}/OS
115 %{php_pear_dir}/PEAR/*
116
117 %{php_pear_dir}/data/*
This page took 0.057076 seconds and 4 git commands to generate.