]> git.pld-linux.org Git - packages/php-pear-PEAR.git/blob - php-pear-PEAR.spec
- conflicts line bugfix
[packages/php-pear-PEAR.git] / php-pear-PEAR.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PEAR
3 %define         _status         stable
4 %define         _pearname       %{_class}
5 %define         _noautoreq      'pear(PEAR/FTP.php)'
6
7 Summary:        %{_pearname} - main PHP PEAR class
8 Summary(pl):    %{_pearname} - podstawowa klasa dla PHP PEAR
9 Name:           php-pear-%{_pearname}
10 Version:        1.4.1
11 Release:        1.1
12 Epoch:          1
13 License:        PHP 3.0
14 Group:          Development/Languages/PHP
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
16 # Source0-md5:  6b39c590203d046f55f207c6c5a7cd18
17 Source1:        %{name}-template.spec
18 Patch0:         %{name}-memory.patch
19 Patch1:         %{name}-sysconfdir.patch
20 Patch2:         %{name}-rpmpkgname.patch
21 Patch3:         %{name}-rpmvars.patch
22 Patch4:         http://glen.alkohol.ee/pld/PEAR-makerpm1.patch
23 URL:            http://pear.php.net/package/PEAR
24 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
25 BuildRequires:  php-pear >= 4:1.0-6
26 Requires:       php-pear >= 4:1.0-5.5
27 Requires:       php-cli
28 Requires:       php-pcre
29 Obsoletes:      php-pear-PEAR-Command
30 Obsoletes:      php-pear-PEAR-Frontend-CLI
31 Obsoletes:      php-pear-PEAR-OS
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The PEAR package contains:
37 - the PEAR installer, for creating, distributing and installing
38   packages
39 - the alpha-quality PEAR_Exception PHP5 error handling mechanism
40 - the beta-quality PEAR_ErrorStack advanced error handling mechanism
41 - the PEAR_Error error handling mechanism
42 - the OS_Guess class for retrieving info about the OS where PHP is
43   running on
44 - the System class for quick handling of common operations with files
45   and directories
46 - the PEAR base class packages
47
48 In PEAR status of this package is: %{_status}.
49
50 %description -l pl
51 Pakiet PEAR zawiara:
52 - PEAR installer do tworzenia, dystrybucji i instalowania pakietów,
53 - mechanizm PEAR_Exception (w fazie alpha) do obs³ugi b³êdów PHP5,
54 - zaawansowany mechanizm PEAR_ErrorStack (w fazie beta) do obs³ugi
55   b³êdów,
56 - mechanizm obs³ugi b³êdów PEAR_Error,
57 - klasê OS_Guess do pozyskiwania informacji na temat systemu
58   operacyjnego,
59 - klasê System do szybkiej obs³ugi typowych operacji na plikach i
60   katalogach,
61 - podstawow± klasy PEAR.
62
63 Ta klasa ma w PEAR status: %{_status}.
64
65 %prep
66 %pear_package_setup
67 %patch0 -p2
68 %patch1 -p1
69 %patch2 -p1
70 %patch3 -p1
71 cd ./%{php_pear_dir}
72 %patch4 -p1
73
74 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{php_pear_dir},%{_bindir}}
80
81 D=$(pwd)
82 pearcmd() {
83         php -d output_buffering=1 -d include_path=".:${D}%{php_pear_dir}" ${D}%{php_pear_dir}/pearcmd.php -c ${D}/pearrc "$@"
84 }
85 pearcmd config-set doc_dir %{_docdir} || exit
86 pearcmd config-set data_dir %{php_pear_dir}/data || exit
87 pearcmd config-set php_dir %{php_pear_dir} || exit
88 pearcmd config-set test_dir %{php_pear_dir}/tests || exit
89 pearcmd config-set sig_bin %{_bindir}/gpg || exit
90 cp $D/pearrc $RPM_BUILD_ROOT%{_sysconfdir}/pear.conf
91
92 %pear_package_install
93 cp -a ./%{_bindir}/* $RPM_BUILD_ROOT%{_bindir}
94
95 install %{SOURCE1} $RPM_BUILD_ROOT%{php_pear_dir}/data/%{_class}/template.spec
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc install.log
103 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pear.conf
104 %attr(755,root,root) %{_bindir}/*
105 %{php_pear_dir}/.registry/*.reg
106 %{php_pear_dir}/*.php
107 %{php_pear_dir}/OS
108 %{php_pear_dir}/PEAR/*
109
110 %{php_pear_dir}/data/*
This page took 0.089978 seconds and 4 git commands to generate.