]> git.pld-linux.org Git - packages/php-pear-PEAR.git/blob - php-pear-PEAR.spec
- fixed dirs
[packages/php-pear-PEAR.git] / php-pear-PEAR.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          PEAR
3 %define         _status         stable
4 %define         _pearname       %{_class}
5 %define         _noautoreq      'pear(PEAR/FTP.php)'
6
7 Summary:        %{_pearname} - main PHP PEAR class
8 Summary(pl):    %{_pearname} - podstawowa klasa dla PHP PEAR
9 Name:           php-pear-%{_pearname}
10 Version:        1.4.0
11 Release:        1.7
12 Epoch:          1
13 License:        PHP 3.0
14 Group:          Development/Languages/PHP
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
16 # Source0-md5:  8a1cf99a637d5420b7749a1c3dfaceb5
17 Source1:        %{name}-template.spec
18 Patch0:         %{name}-memory.patch
19 Patch1:         %{name}-sysconfdir.patch
20 Patch2:         %{name}-rpmpkgname.patch
21 Patch3:         %{name}-rpmvars.patch
22 URL:            http://pear.php.net/package/PEAR
23 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
24 BuildRequires:  php-pear >= 4:1.0-6
25 Requires:       php-pear >= 4:1.0-5.5
26 Requires:       php-cli
27 Requires:       php-pcre
28 Obsoletes:      php-pear-PEAR-Command
29 Obsoletes:      php-pear-PEAR-Frontend-CLI
30 Obsoletes:      php-pear-PEAR-OS
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The PEAR package contains:
36 - the PEAR installer, for creating, distributing and installing
37   packages
38 - the alpha-quality PEAR_Exception PHP5 error handling mechanism
39 - the beta-quality PEAR_ErrorStack advanced error handling mechanism
40 - the PEAR_Error error handling mechanism
41 - the OS_Guess class for retrieving info about the OS where PHP is
42   running on
43 - the System class for quick handling of common operations with files
44   and directories
45 - the PEAR base class packages
46
47 In PEAR status of this package is: %{_status}.
48
49 %description -l pl
50 Pakiet PEAR zawiara:
51 - PEAR installer do tworzenia, dystrybucji i instalowania pakietów,
52 - mechanizm PEAR_Exception (w fazie alpha) do obs³ugi b³êdów PHP5,
53 - zaawansowany mechanizm PEAR_ErrorStack (w fazie beta) do obs³ugi
54   b³êdów,
55 - mechanizm obs³ugi b³êdów PEAR_Error,
56 - klasê OS_Guess do pozyskiwania informacji na temat systemu
57   operacyjnego,
58 - klasê System do szybkiej obs³ugi typowych operacji na plikach i
59   katalogach,
60 - podstawow± klasy PEAR.
61
62 Ta klasa ma w PEAR status: %{_status}.
63
64 %prep
65 %pear_package_setup
66 %patch0 -p2
67 %patch1 -p1
68 %patch2 -p1
69 %patch3 -p1
70
71 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{php_pear_dir},%{_bindir}}
77
78 D=$(pwd)
79 pearcmd() {
80         php -d output_buffering=1 -d include_path=".:${D}%{php_pear_dir}" ${D}%{php_pear_dir}/pearcmd.php -c ${D}/pearrc "$@"
81 }
82 pearcmd config-set doc_dir %{_docdir} || exit
83 pearcmd config-set data_dir %{php_pear_dir}/data || exit
84 pearcmd config-set php_dir %{php_pear_dir} || exit
85 pearcmd config-set test_dir %{php_pear_dir}/tests || exit
86 pearcmd config-set sig_bin %{_bindir}/gpg || exit
87 cp $D/pearrc $RPM_BUILD_ROOT%{_sysconfdir}/pear.conf
88
89 %pear_package_install
90 cp -a ./%{_bindir}/* $RPM_BUILD_ROOT%{_bindir}
91
92 install %{SOURCE1} $RPM_BUILD_ROOT%{php_pear_dir}/data/%{_class}/template.spec
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc install.log
100 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pear.conf
101 %attr(755,root,root) %{_bindir}/*
102 %{php_pear_dir}/.registry/*.reg
103 %{php_pear_dir}/*.php
104 %{php_pear_dir}/OS
105 %{php_pear_dir}/PEAR/*
106
107 %{php_pear_dir}/data/*
This page took 0.087463 seconds and 4 git commands to generate.