]> git.pld-linux.org Git - packages/php-facebook-athenaeum.git/blob - php-facebook-athenaeum.spec
- use virtual names for php deps
[packages/php-facebook-athenaeum.git] / php-facebook-athenaeum.spec
1 %define         php_min_version 5.2
2 %include        /usr/lib/rpm/macros.php
3 Summary:        Tools to extend library services to Facebook users through Facebook applications
4 Name:           php-facebook-athenaeum
5 Version:        0.1.10
6 Release:        4
7 License:        Apache v2.0
8 Group:          Development/Languages/PHP
9 Source0:        http://facebook-athenaeum.googlecode.com/files/fb-athenaeum-%{version}.tar.gz
10 # Source0-md5:  c9805c5d03afeeae61383212224cf293
11 URL:            http://code.google.com/p/facebook-athenaeum/
12 BuildRequires:  rpm-php-pearprov
13 BuildRequires:  rpmbuild(macros) >= 1.461
14 Requires:       php(core) >= %{php_min_version}
15 Patch0:         json-dep.patch
16 Requires:       php(json)
17 Requires:       php(pcre)
18 Requires:       php(simplexml)
19 #Requires:      php-date
20 Suggests:       php(curl)
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # bad depsolver
25 %define         _noautopear     pear(facebookapi_php5_restlib.php)
26
27 # exclude optional php dependencies
28 %define         _noautophp      php-curl
29
30 # put it together for rpmbuild
31 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
32
33 %description
34 Facebook Athenaeum provides libraries an easy to implement Facebook
35 application to extend library resources to students in Facebook. The
36 application is easily customized for your institution and includes an
37 integrated RSS reader, search tools, and a friend locator that allows
38 Facebook users to record their location in the library so their
39 friends can find them.
40
41 %prep
42 %setup -q -n fb-athenaeum-%{version}
43 %patch0 -p1
44
45 # we depend on php 5.2
46 rm -rf libs/facebook_api/jsonwrapper
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{php_data_dir}
51 cp -a libs/facebook_api $RPM_BUILD_ROOT%{php_data_dir}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %{php_data_dir}/facebook_api
This page took 0.14624 seconds and 3 git commands to generate.