]> git.pld-linux.org Git - packages/php-eaccelerator.git/blob - php-eaccelerator.spec
c1da08e9f8358468926fcddc7223a5a62e5f7495
[packages/php-eaccelerator.git] / php-eaccelerator.spec
1 #
2 %define         pkgname         eaccelerator
3 Summary:        eAccelerator module for PHP
4 Summary(pl.UTF-8):      Moduł eAccelerator dla PHP
5 Name:           php-%{pkgname}
6 Version:        0.9.6.1
7 Release:        17
8 License:        GPL
9 Group:          Libraries
10 Source0:        http://bart.eaccelerator.net/source/%{version}/%{pkgname}-%{version}.tar.bz2
11 # Source0-md5:  32ccd838e06ef5613c2610c1c65ed228
12 Source1:        %{pkgname}.ini
13 URL:            https://eaccelerator.net/
14 BuildRequires:  php-devel >= 3:5.1.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %requires_eq    php-common
17 %{?requires_php_extension}
18 Requires:       php(core) >= 5.1.0
19 Requires:       php-session
20 Requires:       php-zlib
21 Conflicts:      php-mmcache
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _webapps        /etc/webapps
25 %define         _webapp         %{pkgname}
26 %define         _sysconfdir     %{_webapps}/%{_webapp}
27 %define         _appdir         %{_datadir}/%{_webapp}
28
29 %description
30 eAccelerator is a further development from mmcache PHP Accelerator &
31 Encoder. It increases performance of PHP scripts by caching them in
32 compiled state, so that the overhead of compiling is almost completely
33 eliminated.
34
35 %description -l pl.UTF-8
36 eAccelerator to dalsze stadium rozwoju akceleratora i kodera PHP
37 mmcache. Zwiększa wydajność skryptów PHP poprzez zapamiętywanie ich w
38 postaci skompilowanej, dzięki czemu narzut potrzebny na kompilację
39 jest prawie całkowicie wyeliminowany.
40
41 %package webinterface
42 Summary:        WEB interface for PHP Accelerator
43 Summary(pl.UTF-8):      Interfejs WWW dla PHP Acceleratora
44 Group:          Libraries
45 Requires:       %{name} = %{epoch}:%{version}-%{release}
46 Requires:       webapps
47 Requires:       webserver(php)
48
49 %description webinterface
50 PHP Accelerator can be managed through web interface script
51 control.php and dasm.php (which requires disassembler and tokenizer).
52 For security reasons it is recommended to restrict the usage of this
53 script by your local IP and setup password based access.
54
55 More information you can find at %{url}.
56
57 %description webinterface -l pl.UTF-8
58 PHP Accelerator może być sterowany ze strony internetowej z
59 wykorzystaniem skryptów control.php i dasm.php (który wymaga modułu
60 obsługującego disassembler i tokenizer). Z powodów bezpieczeństwa
61 zalecane jest, aby ograniczyć korzystanie ze skryptu do lokalnego
62 adresu i ustawić autoryzację hasłem.
63
64 Więcej informacji można znaleźć pod %{url}.
65
66 %prep
67 %setup -q -n %{pkgname}-%{version}
68
69 cat > apache.conf <<EOF
70 Alias /%{_webapp} %{_appdir}
71 <Directory %{_appdir}/>
72         Order allow,deny
73         Allow from 127.0.0.1
74 </Directory>
75 EOF
76
77 %build
78 phpize
79 %configure \
80         --enable-eaccelerator=shared \
81         --with-eaccelerator-userid=http \
82         --without-eaccelerator-use-inode \
83         --with-php-config=%{_bindir}/php-config \
84         %{?debug:--with-eaccelerator-debug}
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{php_extensiondir},%{_bindir},%{php_sysconfdir}/conf.d,/var/cache/%{pkgname},%{_sysconfdir},%{_appdir},/etc/tmpwatch}
90
91 install modules/eaccelerator.so $RPM_BUILD_ROOT%{php_extensiondir}
92 install %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{pkgname}.ini
93
94 cp -a {PHP_Highlight,control,dasm}.php $RPM_BUILD_ROOT%{_appdir}
95 install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
96 install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
97
98 echo "/var/cache/%{pkgname} 720" > $RPM_BUILD_ROOT/etc/tmpwatch/%{name}.conf
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %triggerin webinterface -- apache1 < 1.3.37-3, apache1-base
104 %webapp_register apache %{_webapp}
105
106 %triggerun webinterface -- apache1 < 1.3.37-3, apache1-base
107 %webapp_unregister apache %{_webapp}
108
109 %triggerin webinterface -- apache < 2.2.0, apache-base
110 %webapp_register httpd %{_webapp}
111
112 %triggerun webinterface -- apache < 2.2.0, apache-base
113 %webapp_unregister httpd %{_webapp}
114
115 %post
116 %php_webserver_restart
117
118 %postun
119 if [ "$1" = 0 ]; then
120         %php_webserver_restart
121 fi
122
123 %preun
124 if [ "$1" = 0 ]; then
125         # remove last pieces of cache
126         rm -rf /var/cache/%{pkgname}/*
127 fi
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README bugreport.php doc/php
132 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{pkgname}.ini
133 %config(noreplace) %verify(not md5 mtime size) /etc/tmpwatch/%{name}.conf
134 %attr(755,root,root) %{php_extensiondir}/eaccelerator.so
135 %attr(770,root,http) /var/cache/%{pkgname}
136
137 %files webinterface
138 %defattr(644,root,root,755)
139 %dir %attr(750,root,http) %{_sysconfdir}
140 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
141 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
142 %dir %{_appdir}
143 %{_appdir}/PHP_Highlight.php
144 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/control.php
145 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/dasm.php
This page took 0.121425 seconds and 2 git commands to generate.