]> git.pld-linux.org Git - packages/php-cs-fixer.git/blob - php-cs-fixer.spec
82b322a4ed3cf63ac3d0d71d680e24cf3b12f492
[packages/php-cs-fixer.git] / php-cs-fixer.spec
1 # TODO
2 # - unbundle phar, use system libs, etc
3 %define         php_min_version 5.3.3
4 %include        /usr/lib/rpm/macros.php
5 Summary:        PHP Coding Standards Fixer
6 Name:           php-cs-fixer
7 Version:        0.3.0
8 Release:        0.4
9 License:        MIT
10 Group:          Development/Languages/PHP
11 Source0:        http://cs.sensiolabs.org/get/%{name}.phar
12 # Source0-md5:  5cefff68fe01e635086de6b8b2dd35f7
13 URL:            http://cs.sensiolabs.org/
14 Requires:       /usr/bin/php
15 Requires:       php(core) >= %{php_min_version}
16 Requires:       php(phar)
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The PHP Coding Standards Fixer tool fixes most issues in your code
22 when you want to follow the PHP coding standards as defined in the
23 PSR-1 and PSR-2 documents.
24
25 If you are already using PHP_CodeSniffer to identify coding standards
26 problems in your code, you know that fixing them by hand is tedious,
27 especially on large projects. This tool does the job for you.
28
29 %prep
30 %setup -qcT
31 cp -p %{SOURCE0} .
32
33 # breaks signature:
34 #%{__sed} -i -e '1 s,#!.*php,#!/usr/bin/php,' php-cs-fixer.phar
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{_bindir}
39 install -p php-cs-fixer.phar $RPM_BUILD_ROOT%{_bindir}/%{name}
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.052675 seconds and 2 git commands to generate.