]> git.pld-linux.org Git - packages/photoqt.git/blob - photoqt.spec
qt ver
[packages/photoqt.git] / photoqt.spec
1 # TODO
2 # - with GM?
3 # - optional (runtime) deps:
4 #  - XCFtools - https://github.com/j-jorge/xcftools
5 #  - libqpsd - https://github.com/Code-ReaQtor/libqpsd
6
7 %define qtver   5.1
8 Summary:        Simple but powerful Qt-based image viewer
9 Name:           photoqt
10 Version:        1.2
11 Release:        1
12 License:        GPL v2
13 Group:          Applications
14 Source0:        http://photoqt.org/pkgs/%{name}-%{version}.tar.gz
15 # Source0-md5:  bc0233279c86db39dc2482583697c9b3
16 URL:            http://photoqt.org/
17 BuildRequires:  GraphicsMagick-devel
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  Qt5Gui-devel >= %{qtver}
20 BuildRequires:  Qt5Multimedia-devel >= %{qtver}
21 BuildRequires:  Qt5Svg-devel >= %{qtver}
22 BuildRequires:  qt5-linguist >= %{qtver}
23 BuildRequires:  cmake
24 BuildRequires:  rpmbuild(macros) >= 1.596
25 Requires:       desktop-file-utils
26 Requires:       gtk-update-icon-cache
27 Requires:       hicolor-icon-theme
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Simple but powerful Qt-based image viewer.
32
33 %prep
34 %setup -q
35
36 %build
37 install -d build
38 cd build
39 %cmake \
40         -DGM=NO \
41         -DEXIV2=YES \
42         ..
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} -C build install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %update_desktop_database
55 %update_icon_cache hicolor
56
57 %postun
58 %update_desktop_database
59 %update_icon_cache hicolor
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README CHANGELOG
64 %attr(755,root,root) %{_bindir}/photoqt
65 %{_desktopdir}/photoqt.desktop
66 %{_iconsdir}/hicolor/*/apps/photoqt.png
This page took 0.05956 seconds and 3 git commands to generate.